Welcome to the Linux Foundation Forum!

bash programming

Hello I am taking a linux scripting class at a community college in FL, and I encounter some difficulties.

I created a direcotry named HW where I have all my homeworks.

Since the last few days, I can not access the content of the HW directory, and I can not write any script using "vi"

When I enter:

cd HW # I get the following message

bash: cd: HW: Permission denied

If I try to write a script using "vi", when I try to save it, I get the message:

"name_of_file" E212: Can't open file for writing.


  • Goineasy9
    Goineasy9 Posts: 1,114
    The folder "HW" is owned by root and not the user. Somehow when using vi (maybe you originally started it in terminal when logged in as root) you created the folder as root. Try becoming root in a terminal ("su enter <password> enter), then do cd HW (or cd /HW) and see if you have access.
    You can change the owner of folder HW by becoming root and executing the command chown <username> HW.

    Hope this helps
  • Hello< thank you very much for your help.

    I did enter su enter enter, but I get the message: password incorrect. When asked; I enter my password, and it is incorrect.
  • Goineasy9
    Goineasy9 Posts: 1,114
    Only you know your root password, are you sure your using the "root" password and not your user password? Maybe your caps lock key is on, Linux sees passwords differently if typed in caps. (Example: password will be seen differently than PASSWORD by the system).
    Did you hit enter once or twice after typing su?
    su <enter>
    password <enter>
    should give you a root prompt if you type in the correct root password.
  • Wicked
    Wicked Posts: 24
    If you still can't get into it because you forgot the root password you set on installation, you can reset the root password. This link should work. I tried it out on my system and it worked like a charm

    Hope this helps :cheer:

  • I know my password was spelled correctly, so I guess I have a user password.
    When I log on I use a computer at my community college.
  • The link does not work, but thank you
  • Wicked
    Wicked Posts: 24
    It could possible be because you're on a school computer and the admin there has removed your rights to that file for some reason.

    Maybe Goineasy9 can help you out more. or you can talk to the person who's in charge of the network, see if you can get the files back from him. then set up a new directory under your current username.
  • yes.. i recommend Mr. GoinEasy9 to solve that problem but if you don't mind.. maybe i can help you..

    1. Open your "xterm"
    2. type the command "sudo su".
    3. cd "target path"

    try that... :D PM or reply me if you solve the problem.. thanks...
  • Rovanion
    Rovanion Posts: 73
    Yeah try using sudo instead of su.
    If you're account is in the sudoers group or in the group wheel you will with your own password be able to grant yourself root permissions.
  • after using sudo, I get the message:
    leo is not in the sudoers file. This incident will be reported.
  • Goineasy9
    Goineasy9 Posts: 1,114
    I think you ought to get in touch with the system administrator and explain what your trying to do. If the incident will be reported, you might want to report it first. I think you crossed the permissions line somewhere. <joke> LOL...when I was in school, something like this could be put on your permanent record. </joke>
  • Hello Goineasy9:

    I did get in touch with my instructor, even though he could not fix the problem, the incident was reported, and he accepted my work.

    Thank you for your help and time, it was very valuable to me.

  • Goineasy9
    Goineasy9 Posts: 1,114
    No problem Leo....glad it all worked out.


Upcoming Training