Welcome to the Linux Foundation Forum!

Arch Won't Boot

Okay... Got a problem hope one of you can fix...

Hated Vista, so switched to Ubuntu, completely erasing Vista from existence. It was nice, but not quite what I wanted. So I changed to Kubuntu. Again, worked well, but not quite there. Decided to try Arch. Now I'm wishing I would've stuck with Kubuntu...

While attempting an install to my HP Pavillion dv7600, the Arch Install CD hanged. I let it work on itself for about an hour, but it did no good. Had to do a hard reboot.

Now, lo and behold, I go to start my computer and up pops the following:

Booting 'Arch Linux'

root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz26 root=/dev/disk/by-uuid/CE30-78B6 ro
[Linux-bzImage, setup=0x3600, size=0x1abaa0]
initrd /kernel126.img

Error 15: File not found

Press any key to continue...

There are three lines of code to edit, when I choose the "edit" option:

root (hd0,0)
kernel /vmlinuz26 root=/dev/disk/by-uuid/CE30-78B6 ro
initrd /kernel126.img

I only have one hard drive, so it should stay on (hd0). I have attempted to change the partitions, and received the following response:

root (hd0,1)
Filesystem type unknown, partition type 0x82
kernel /vmlinuz26 root=/dev/disk/by-uuid/CE30-78B6 ro

Error 17: Cannot mount selected partition

Press any key to continue...

This happens all the way up to partition 4, when it says "Error 22: No such partition.

I have tried to reinstall Arch, using ISO's with versions i686 and x86_64, with no luck.

I have also tried ISO's with Mint 7 and Ubuntu 9.04. Again, no joy. I even tried systemrescuecd-x86-1.2.3. Nada.

I still get that first "Error 15" screen. Arch Fallback does the same thing. I believe it is because Arch is booting to the hard drive first. That is what "initrd" is, correct? I enter BIOS at startup and changed the boot order - multiple, multiple times - and get the same "Error 15" message. I have spent about 30 hours over the past 4 days trying to fix this. Any help you can give would be appreciated. Otherwise, I am afraid I am "Fracked".


  • amnesia
    amnesia Posts: 60
    Well, considering you totally erradicated your file system?

    Considering the CD hung and you killed your computer, the probability of you having a complete OS installed is 0, therefore -- the simpliest answer I can give is just reinstall Linux and when partitioning, delete the ones currently listed and re-create the partitions.. It'll write a new MBR, etc -- As for your CD hanging, check it for deficiencies before you try to reuse it... There's ways you can actually just fix it from the boot cd, but that's a longer story -- if there's nothing there you care about, go ahead and reinstall from scratch
  • Hi...initrd is the initial ramdisk...it's not the harddisk itself. Rather it is the temporary filesystem that is used to bring up the kernel and mount the main filesystem. Think of it as a starter on your car engine. It provides the juice to get the engine started until it is self sustained.

    Normally in a standard Linux set up the kernel image that is initialized (called vmlinuz) lives in your /boot partition. From what I can see in your grub set up yours is referencing just /
    Filesystem type is ext2fs, partition type 0x83
    kernel /vmlinuz26 root=/dev/disk/by-uuid/CE30-78B6 ro
    [Linux-bzImage, setup=0x3600, size=0x1abaa0]
    initrd /kernel126.img

    Should be
    kernel /boot/vmlinuz26 root= etc etc etc

    Either way your grub boot partition is foobooed (good technical term for broke, corrupt or gone. It sounds like you've tired multiple things so I'm not sure what exists or how corrupt it might be. A simple thing to try is to boot into a live CD and then chroot into the filesystem and then run the following commands:

    1. grub
    2. find /boot/grub/stage1
    3. root (hd0,0)
    4. setup (hd0)
    5. quit

    It might even be a better idea to start with fdisk -l /dev/hda (or sda) to see what partitions it shows on the disk. You are looking for the boot partition or if you went strictly to MBR.

    Then reboot. If grub is still capable of being repaired it should boot up correctly. If not there are other issues and we'd need to see the errors you are getting.

    By the way, the error you received on hd0,1 is from you trying to set the swap partition as the root. That won't work. You know it is swap by the type number of 82.
  • amnesia
    amnesia Posts: 60
    Damn, you've got a way with the new-to-linux guys - I guess I was just more focused towards the idea that his CD hung during an install and pretty much screwed the layout. :)
  • Dute
    Dute Posts: 4
    I would absolutely LOVE to install from scratch at this point, as I had already saved all pertinent files to a flash drive prior to attempting to install Arch... But, I am new to Linux, and my programing experience is limited to scripts in IRC back in the early 90's (you KNOW that makes you laugh).:laugh:

    So... How do I go about removing GRUB or getting into CHROOT? Try a fresh install? I tried... The computer will not boot from the CDROM... I've tried 4 different ISO disks with different Linux systems... The disc runs, but does not boot the install programs.

    Change the boot order in BIOS? Tried it several times... Plus, it already shows that the CDROM is the first to boot. Even tried booting to the HD first a couple of times. All with the same result.

    Kryptikos: You call it FooBooed, I call it FUBAR'd (Fracked Up Beyond All Recognition, to put it politely). So, unless the Live CD will boot to a computer with no functioning OS that either (a) refuses to listen to BIOS screaming at it to boot from the ISO image CD or, (b) simply will no longer read discs from the CDROM, I am guessing I will have to become versed in LINUX programing...


    Is there any way to tell GRUB to delete, disable, or go tell itself to pound sand so BIOS can boot from a CD?

    Come on... I know you guys love a challenge as much as you love seeing newbies TOTALLY screw up their systems! Even with all this, I STILL like Linux much better than Vista... Never tried a Mac before, though... Hmmm...
  • amnesia
    amnesia Posts: 60
    That does not make any sense what so ever
    aslong as the boot order points to the CD-R before it boots from the HDD's, it should boot from CD, unless the CD is corrupted or missing the boot code or you have a bad CD-R drive

    If you have the option to change the boot order 'One Time Only option' via an F key (usually F6) it allows you to change the startup sequence without ever having to physically enter BIOS, would be an option aswell (if possible).

    kryptikos was right, had you actually installed a complete operating system, to me it sounds like you don't have the option to 'correct grub', it can't boot what you don't have (you said your CD hung during installation and you did a hard reboot) which probably 'fubar'd' your file systems layout. Now, what you 'CAN' do since Microsoft is so notorious about hijacking the MBR without hesitation is just try to boot a copy of vista, get all the way to the partition screen and just let vista redo your partitions and do an actual format, not just 'quick', afterwards don't completely install vista just reboot and you'll have a brand new NTFS file system with nothing -- that'll get rid of grub

    OR, you can download a Decent copy of Linux

    Slackware, Debian, Gentoo and be happy :> <- these guys can/will and most definitely resolve your problem.

    Keep in mind, sometimes the hardest looking OS is the easiest to install -- just a thought if you decide ^

    IF none of this works -- it's probably faulty hardware, I know that there's no way possible other than the stuff I mentioned earlier, and maybe a few other things that you shouldn't be able to boot a good copy of linux

    BIOS don't care about your MBR until it calls for it.

    So, maybe if this is an older PC your drives laser diode may be dirty, cause it to skip sectors which would be a good reason why your installation failed

    So, maybe if you have another drive you should try that one

    Other than that - BIOS may need updated (flashed)

  • Dute
    Dute Posts: 4
    Okay, we can close this topic, as it has been solved...

    For some reason, the CD drive would not read the ISO CD's I loaded. I attempted a total of five, count 'em, FIVE CD-R's loaded with ISO's of Ubuntu, Mint, two versions of Arch, and a Linux System Rescue CD. Nothing. I finally downloaded a Kubuntu install ISO onto DVD format, threw it in, and it started right up. I do not get it. Either I have a whole stack of bad 700 MB CD-R's, or my drive just prefers the DVD's over the CD-R's... Oh well... Thanks for all the help, all!
  • Glad to hear it worked out and you were able to get your box up and running.

    With respect to the CD-R, alot of the mass produced CD do have problems...I've seen then when replicating distros. The other thing you can check is perhaps the links you pulled the ISOs from were not complete or had errors. A great thing to check is the "md5sum". Most distros worth their weight will always have their checksum number available for the version you are downloading.

    Either way happy to hear the problem is resolved :)


Upcoming Training