Welcome to the Linux Foundation Forum!

weird problem running programs as normal user


Hi all,

If I try to start openoffice as a normal user, the spash screen shows up briefly, and that's it. After some investigation (strace, gdb) it seems openoffice dies with a SIGBUS signal.

The same goes for NaNT (a build tool based on mono).

These programs do work when I run them as root.

So I thought it might be something smelly in my local config files, so I created a fresh new user and tried again. Still no luck. For some reason some programs won't run under a unprivileged account but they do under root.

Does anyone have a idea what's going on?

oh, I use a opensuse 11.1 x86_64 installation.



  • kryptikos
    Hi Bofhorg

    Just a couple of quick questions. Is the openoffice the version that was included with your openSUSE? Have you tried installing the package again via the repositories? What version of Java do you have on the box? Was your 11.1 an upgrade from 10.3 or a full install? What version of Oo are you using?

    Might try renaming the user Oo folder and letting Oo regenerate it with defaults. Could be conflict there:

    mv /home/<user>/.ooo-2.0/ /home/<user>/.ooo-2.0.old


Upcoming Training