Welcome to the Linux Foundation Forum!

ati-catalyst 9.6 on kernel 2.6.30(x86) Crash!!

markding Posts: 3

Anyone can run ati-catalyst 9.6 on kernel 2.6.30 well?

I'm useing Archlinux (i686) on kernel 2.6.30 with catalyst 9.6, but badly video driver. Run glxgear or glxinfo then crash everytime, everytime!!:angry: god know it.

The catalyst 9.6-4 in aur, Dose anyone can fix it?

PS:Video Card is ATI Mobility Radeon HD 3450 (M82,PCI:1002-95C4)

PS2: Yesterday 9.7 is out, Crash again.

PS3: I jump at Archlinux(x64) at last, It works now, just works.


  • woboyle
    woboyle Posts: 501
    What video card and driver are you using?
  • Rovanion
    Rovanion Posts: 73
    As far as of what I've heard the 9.6 driver doesn't work with 2.6.30. Don't know about 9.7. They're all horribly written propitary plumps anyways.
  • Goineasy9
    Goineasy9 Posts: 1,114
    I'm not positive about this, but, with the 2.6.30 kernels, weren't a lot of firmware drivers removed from the kernel? With the new kernel in Debian Sid, ATI users had to "apt-get install linux-firmware" in order to get their cards working. With linux-firmware some were able to make ATI drivers work, others still had problems.
    This is why I stick with Nvidia. Their drivers may be closed source, but at least they make an attempt to have them working with recent linux kernels.
  • sfnightfire
    9.6 Catalyst drivers havent really worked since a few kernels ago... it just basically does not work..
  • DavidDock
    Alright, it seems a lot of people are curious about whether ATI catalyst driver 9.6 runs in F11, including me, I decided to give it another try - the first try was a failure when I tried to downgrade kernel to directly. Now, the result of second try is out, it works.

    That is, when you do the following steps. It is worth mentioning that there is absolutely NO guarantee that it will work in your system. If you want a stable system, I suggest a little more patience while playing with community driver, which in my opinion deserves praises, since it is getting better all the time.

    My hardware specifications:
    Athlon X2 7750 BE + DDR2-1066 2G x2 + Asrock 790GMH/128M + integrated graphics HD3300

    OS: Fedora 11 x86_64

    1) download fc10 kernel source rpm:

    $wget http://kojipkgs.fedoraproject.org/packages/kernel/

    2) rebuild kernel for F11

    $rpmbuild --rebuild kernel-

    note: keep it in mind, this step may take while and require about 7G disk space
    3) install new kernel and kernel-devel packages

    #yum localinstall kernel- kernel-devel-

    note: you need to disable gpgcheck temporarily.
    4) download ATI catalyst driver

    $wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-9-6-x86.x86_64.run

    note: if you have a different chipset, choose what you need accordingly.
    5) install ATI catalyst driver

    #sh ati-driver-installer-9-6-x86.x86_64.run

    6) check out xorg.conf file. If you don't have a /etc/X11/xorg.conf beforehand, I recommend create it before step 5 by:

    #Xorg -configure :1
    #cp ~/xorg.conf.new /etc/X11/xorg.conf

    7) disable SELinux by append 'selinux=0' . Yeah, you have to do this, otherwise, at least in my box, it won't boot.

    #sed -ie 's/\(kernel .**\)/\1 selinux=0/' /boot/grub/grub.conf

    8) reboot system, and good luck!
    9) when you are tired of fglrx, or rpmfusion release fglrx rpms, you just need to do:

    #cd /usr/share/ati
    #yum remove kernel- kernel-devel-

    then everything back on track again.

    Known issues:
    1) the alsa driver in kernel is 1.0.17, so, if your audio card is not supported like mine, you'd better download alsa driver 1.0.20 and install it.
    2) some system services may need to be manually enabled again.
    3) the driver runs basically stable here, but I find the window minimize/maximize function does not work rightly. But I'm not sure whether it's a compiz problem or fglrx issue.

    Ok, the difference of glxgears benchmark when using radeon or fglrx driver is quite noticable, about 330~360 fps (radeon) vs 2000~2900 fps (fglrx), although the difference of realtime performance aren't that different.

    Another thing, when selinux is enabled, F11 won't boot, in my case, it hangs at system logger after auditd failed message. So, i whether it is a selinux conflict or audit daemon issue. I hope someone may give a hint here.

    Yes that is a nice idea but have you ever thought of going up to the biggest guy on the subway and telling him your thoughts on this. I wonder what he might do, or would you even do it.

    wow gold
  • markding
    Maybe I need got a fedora, but I don't use fedora. So skip it.
  • i92guboj
    Hi, ;)

    A couple of things:

    [li]glxgears is NOT a benchmark, it doesn't really matter how much fps does it report as long as DRI is working, also, take into account that if your monitor refreshes the screen, let's say, 60 times per second, it doesn't really matter how much fps your card can do, your monitor will not magically be able to output 3200 frames per second, period.[/li]
    [li]fglrx (catalyst, or whatever you call them) DO NOT WORK officially with anything above, which is the latest .28 release of the linux kernel. 2.6.29 and 2.6.30 releases are plainly unsupported. This holds valid for fglrx 9.6 and 9.7. Yes, I am perfectly aware that there are patches around to make them kind-of-work with newer kernels, but if you use them expect all kind of annoyances (spam logs which will fill your /var/ partition, hangs, lockups, acpi stuff not working, etc etc etc), you get the idea. Of course, the magically work for *some* persons, which doesn't mean they truly work at all.[/li]

    So, to sum up: if you truly need the propietary fglrx driver, the best idea is to stay at linux 2.6.28.x.


Upcoming Training