Welcome to the Linux Foundation Forum!

no sound

I can't get any sound at all on any linux distros (live or installed)

that I tried.

alsamixer and alsactl seem to be working


# cat /proc/asound/cards

outputs this

0 [Intel ]: HDA-Intel - HDA Intel

HDA Intel at 0xdf300000 irq 11

Whenever I try listen to a sound file, the application

(amarok, k3b, ...) I use remain silent and

doesn't display an error message

I have an hp pavilion dv4-1199ef laptop (purchased

in March 2009).

I have no clue on what might be the reason for this

(alsa, kernel, ...?)


  • nulld0g
    nulld0g Posts: 3
    Are you sure that your sound card is working?
  • vtel57
    vtel57 Posts: 164
    I had this exact same issue in Debian before. Remove your libesd0 and install libesd-ALSA0 instead. That solved it for me right away.


  • abrenar
    abrenar Posts: 117
    nice one friend eric, you solve my problem without asking heheheh,

  • vtel57
    vtel57 Posts: 164
    Glad that worked for you, Arben! :)
  • abrenar
    abrenar Posts: 117
    i already forgot to ask that question hehehe.

    thanks, also to vonbiber for asking about sound problem

  • vonbiber
    vonbiber Posts: 28
    It's working on my vista partition.
  • vtel57
    vtel57 Posts: 164
    That has nothing to do with it. Your Vista is an entirely different operating system from your Linux installation. When you boot into Linux, Vista doesn't exist, as far as your computer is concerned.

    What distribution of Linux are you running? How new are you to this stuff? If very new, I'll take extra care trying to explain to you how to change those library files that I mentioned in my post above.
  • vonbiber
    vonbiber Posts: 28
    I meant the hardware is working
    I'm an intermediate user. I'm comfortable with the console,
    the shell, (re)building the kernel, etc.
    the hda intel is built in the kernel (not as a module)
    I use slackware 12.2
    my laptop is very recent: hp pavilion dv4-1199ef
  • vtel57
    vtel57 Posts: 164
    Ah! OK. I see what you mean.

    Have you made any progress? Do you have system sounds: startup, shutdown, error, etc.?
  • vonbiber
    vonbiber Posts: 28
    I do get the beep (that I turn off because I find it annoying)
    other than that nothing
    in kde even when I turn the notification system sounds
    there's nothing either
  • vtel57
    vtel57 Posts: 164
    OK, system beep is part of your hardware on your mobo. It has nothing to do with your audio in your operating system. It looks to me like you have NO audio whatsoever in your operating system right now.

    From the command line as root:
    # alsaconf

    Follow the steps, reboot. Let me know if you have sound.
  • vonbiber
    vonbiber Posts: 28
    # alsaconf
    displays this message
    no supported PnP or PCI card found

    and yet, when I run this
    # lspci | grep -i audio

    it displays this
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

    I noticed that slackware uses a

    I know that it's run at boot time (it's in mod+x) and I don't
    get any error messages in dmesg
  • vtel57
    vtel57 Posts: 164

    I'm beginning to run out of ideas. See HERE for some things to check.

    Also, I noticed you registered at Scot's. I sent you a Welcome PM, by the way. Post about this in All Things Linux there. Bruno will solve it for you. I can almost guarantee it. :)
  • saturn721
    saturn721 Posts: 2
    Try this
    > modprobe snd-hda-intel
    If there is not this module, see config kernel
    >cat /boot/config-bla-bla-bla | grep CONFIG_SND_HDA_INTEL
  • vonbiber
    vonbiber Posts: 28
    my snd_hda_intel was built in the kernel, and not as
    a module
    but even when it's built as a module (which I did with
    the last kernel I built---linux- it's still not working
    and the lsmod does display all the sound modules

    given the number of posts I saw elsewhere I think there's
    an issue with this card
    so I keep trying to build new kernels, hoping that eventually
    someone'll come with a fix
  • saturn721
    saturn721 Posts: 2
    Good. When you do so. Know output
    >modinfo snd-hda-intel
    There is lot a parametrs.
    parm: index:Index value for Intel HD audio interface. (array of int)
    parm: id:ID string for Intel HD audio interface. (array of charp)
    parm: enable:Enable Intel HD audio interface. (array of bool)
    parm: model:Use the given board model. (array of charp)
    parm: position_fix:Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF). (array of int)
    parm: bdl_pos_adj:BDL position adjustment offset. (array of int)
    parm: probe_mask:Bitmask to probe codecs (default = -1). (array of int)
    parm: single_cmd:Use single command to communicate with codecs (for debugging only). (bool)
    parm: enable_msi:Enable Message Signaled Interrupt (MSI) (int)
  • echangwi
    echangwi Posts: 1
    Fedora seems to work without any issues
  • woboyle
    woboyle Posts: 501
    It is not uncommon for the ALSA sound system to have one of the required output volume levels, such as PCM, set to 0. Start up your sound mixer and check for this situation. The result of this issue is no sound. I had the same problem on my CentOS system originally and only with some futzing with the mixer figured this out. Subsequently, I have read posts in linuxforums.org from many other people with the same problem.
  • vonbiber
    vonbiber Posts: 28
    I just checked with alsamixer
    my pcm level is not set at 0 (it's set at 71)

    one weird thing I noticed is that the sound card uses
    a certain irq on my installed slackware
    and another one on my live slax linux

    here's the 2nd line of 'cat /proc/asound/cards'
    from slackware;
    HDA Intel at 0xdf300000 irq 11

    and from slax:
    HDA Intel at 0xdf300000 irq 22
  • darkixion
    darkixion Posts: 41
    I'm late to this thread, but what is the model of your machine? You might need to edit /etc/modprobe.d/alsa-base.conf and add in an option for your card.

    For example, my laptop needed the following option (which probably won't be the same as what you need):
    options snd-hda-intel model=mitac probe_mask=1

    Whereas my cousin's laptop (a Toshiba Satellite Pro) needed this line:
    options snd-hda-intel model=3stack

    Hope this puts you on the right track.

  • vonbiber
    vonbiber Posts: 28
    I have an hp laptop
    hp pavilion dv4-1199ef

    I already wrote an /etc/modprobe.d
    where I tried different values for model
    based on what I read in the
    /Documentation/sound/alsa/HDA-models.txt (or something like
    this) in my kernel source tree, and that'd could fit for an hp

    the latest I tried was model=laptop

    it seems the alsa files in linux- are not up to date with
    the latest alsa (1.20) because in the alsa docs from the
    latest version I dowloaded there were some other models
    not listed above, such hp-dv5 (which might cover the
    hp dv4 series)
  • Hello This is Sam and I want to know how to install audio driver in linux operating system


    find lawyer


Upcoming Training