Welcome to the Linux Foundation Forum!

Kubernetes fundamentals : Lab3 : Invalid reference format error on etcd pulls

insertyawl
insertyawl Posts: 4
edited November 2017 in LFS258 Class Forum

Hi,

I am walking through the Kubernetes fundamentals course and am trying out the lab-3 examples. It requires setting up an etcd server, manager and scheduler.

The command is:

$​ ​docker​ ​run​ ​-d​ ​--name=k8s​ ​-p​ ​8080:8080 gcr.io/google_containers/etcd:3.1.10​ ​etcd​ ​--data-dir​ ​/var/lib/data

I get a " docker: invalid reference format." error.

I tried pulling the image docker pull 0 gcr.io/google_containers/etcd:3.1.10​ and get invalid reference format. 

I looked up on dockerhub and don't see the images there. 

Is there somewhere else these images exist?

I'm sure the next commands will fail as well as it references the same repos on hub. Any help?:

docker​ ​run​ ​-d​ ​--net=container:k8s gcr.io/google_containers/hyperkube:v1.7.6​ ​/apiserver --etcd-servers=http://127.0.0.1:2379​ ​\ --service-cluster-ip-range=10.0.0.1/24​ ​\ --insecure-bind-address=0.0.0.0​ ​\ --insecure-port=8080​ ​\ --admission-control=AlwaysAdmit

 

Comments

  • sebgoa
    sebgoa Posts: 23
    edited November 2017

    My guess is that you are making a typo. I tried and the image is there and pulls fine.

    There is only one underscore between `google` and `containers`. Can you try:

     

    `docker pull gcr.io/google_containers/etcd:3.1.10`

     

     

  • insertyawl
    insertyawl Posts: 4
    edited November 2017

    Thanks sebgoa. You are right. I think it was a copy/paste mistake. I think the markup there was causing it.

    I manually typed it and it worked. Thanks for taking the time to explain.

  • chrispokorni
    chrispokorni Posts: 1,135
    edited November 2017

    Hi, I get the same 'invalid reference format' error regardless if using 'google_containers' or 'google-containers'.

    I also tried the simple docker pull sugested, both ways with underscore "_" and dash "-" and receive the same 'invalid reference format' error.

    While checking the container registry, the Show Pull Command shows "gcloud docker -- pull gcr.io/google-containers/etcd:3.1.10" with a dash "-" rather than an underscore "_".

    What else should I try?

  • ojmhetar
    ojmhetar Posts: 1
    edited November 2017

    I had the same issue. Looks like there are hidden characters when you try to copy the link from the pdf. Try typing out the link instead of pasting

Categories

Upcoming Training