Welcome to the Linux Foundation Forum!

Chapter 12 Lab - NewRelic + Pivotal Cloud Foundry

NigelWright Posts: 1
edited June 2017 in LFD232 Class Forum

Hi everyone,

Just a heads up - I'm working on Pivotal Cloud Foundry, and could not get the comms working between CF and New Relic. I was getting 401 errors (authentication required) and the manage service link for New Relic in PCF would fail with a wrong account. It seems that creating a New Relic account as per the lab guide and supplying those credentials wont work (or at least wouldnt for me).

Here's how I solved it:

Skip the New Relic account creation section..instead create the new relic service with the CLI (cf create-service newrelic standard mynewrelic). Bind it as normal, and restage as normal. To access the dashboard, you will use the SSO between PCF and NewRelic. To do this:

Login to the PCF console, find your roster app, go to the services, select the New Relic service, and click the 'Manage' button. This will log you into New Relic via SSO, and take you to your dashboard. I also had to increase the memory of the Roster app from 512 (which would crash every time) to 1G.

Just my experience, hopefully that helps someone :)




  • amuller
    amuller Posts: 14
    edited July 2017


    Thanks for heads up! I think there is something wrong in the exercice because I try to follow carefully steps described into the Lab sheet, but it did never worked (I can't see anything into NewRelic dashboard). 

    When I look at the log traces of my application, I see:

       2017-07-22T15:32:40.37+0200 [APP/PROC/WEB/0] OUT 2017-07-22 13:32:40.374  WARN 13 --- [           main] o.s.cloud.AbstractCloudConnector         : No suitable service info creator found for service chapter12-newrelic Did you forget to add a ServiceInfoCreator?




  • spgreenberg
    spgreenberg Posts: 86
    edited July 2017

    Hi Nigel,

    I verified this exercise is working on PWS.  However, some of the instructions were unclear so I have updated them.  I have submitted these to Flavia to be updated in the platform. I am not sure how long this takes until you see the updated version.

    As you are working through the exercise, here are a few things to check:

    • Don't follow the new relic instructions but only what is on the exercise (I clarified this in the new version and added screenshots though I am not sure how long it takes the updates to show up).
    • Your UPSi name contains the string "newrelic"
    • Restage (not restart) your roster app. Restaging is necessary to force recreation of the droplet with the added newrelic agent.
    • Be sure to look for out of memory errors.  NewRelic adds an agent to the droplet and you should have to add memory to your app to support this new agent.  We purposely don't mention this as we expect students to figure this out.  Troubleshooting is a big part of the certification.

    The NewRelic service in the PWS marketplace is specific to Pivotal. It is not available in all Cloud Foundry marketplaces. However, this exercise should work on any Cloud Foundry.

  • fcioanca
    fcioanca Posts: 1,761
    edited July 2017


    The course was updated this morning with the revised New Relic lab. To ensure you have access to the latest updates, please clear your cache before accessing the course.




  • amuller
    amuller Posts: 14
    edited August 2017

    that works now, thanks!



Upcoming Training