Welcome to the Linux Foundation Forum!

How to boot manjaro 17 from a bootable USB ISO without loading GRUB

noptycopty Posts: 1
edited April 2017 in New to Linux

I've got a Surface Pro 3 running windows 10 with UEFI. I downloaded the ISO for manjaro 17 gnome and created a bootable USB for it using rufus (using the "GPT partition scheme for UEFI") setting. Changing the boot order to USB first got me to the GRUB interface, but I got:

Error: unknown filesystem

grub rescue>

I tried a standard solution online, which is to run these commands:


(hd0) (hd1)

set prefix = (hd0)/boot/grub

set root = (hd0)

set boot = (hd0)

insmod normal

But insmod normal returns "error unknown filesystem", and it does this if I do the same thing with the hd1 partition. I'm not sure if either of them are my USB.

So I want to bypass grub altogether and use refind or something else to boot into the manjaro installer. How do I do this? I also noticed that cmdpath = (hd0)/EFI/BOOT I think, so I figure I may not actually be booting from the USB and instead am using GRUB from the harddisk?

I should note that my drive is likely corrupted, as when I tried to shrink the C: drive in windows partition manager, it returned a "the parameter is incorrect" error. I used easeus partition manager instead to make unallocated space for the Linux partitions.


Upcoming Training