Welcome to the new Linux Foundation Forum!

RE: Signing Into GRUB But...

silver2rowsilver2row Posts: 29
edited February 2017 in LFS201 Class Forum

Hello...I cannot sign into GRUB before the graphical interface is applied to my screen. I tried to put in my password but the process is applied too quickly and I cannot type fast enough to enter into non-graphical mode with GRUB.

 

 

 

Comments

  • coopcoop Posts: 339
    edited February 2017

    you probably have to do some editing of /etc/default/grub.  When there is no other operating system on the computer some distributors do this (ugh...) -- prevent seeing a screen.  Go into that file and you need to comment out the line:

     

    GRUB_HIDDEN_TIMEOUT=0 (i.e., put a # in front of it).  You may also want to change the timeout.

     

    Reboot and you shoudl see the grub screen.  (I've seen this mostly on Ubuntu)

  • silver2rowsilver2row Posts: 29
    edited February 2017

    Hello...I pressed Esc a couple of times and it lead me to GRUB but I cannot get into non-graphical mode for some reason. I researched the idea and still could not come up with a viable solution.

     

  • UBUNTU 16 

    1. Edit GRUB configuration file

    $ sudo vi /etc/default/grub

    #GRUB_HIDDEN_TIMEOUT=0

    #GRUB_HIDDEN_TIMEOUT_QUIET=true

    GRUB_TIMEOUT=10

    :x! (save & exit)

    2. Update GRUB configuration file

    $ sudo update-grub

    3. Restart system

    $ reboot

    4. Make necessary changes to login to runlevel 3 (text mode)

    When you see the GRUB boot screen, press "e" (edit)

    Scroll down to the kernel command line (1st line that starts with "linux")

    and append 3 to it

    Finally, press Ctrl x to boot into text mode

    5. Login to text mode

    Once in text mode, login using your normal user account

    6. Return to runlevel 5 (GUI)

    $ sudo service lightdm restart

  • luisviveropenaluisviveropena Posts: 364
    edited February 2017

    Hi silver2row,

    Did you edit /etc/default/grub as Coop instructed you, and then executed sudo update-grub and restarted the system?

    Regards,

    Luis.

  • silver2rowsilver2row Posts: 29
    edited February 2017

    No...not yet. I will get on it soon and get back to everyone. Thank you again for your support.

     

  • Hello...I went into my default directory and found the file grub. I was denied permission to write to that file, i.e. /etc/defualt/grub. I am sorry. I followed the instructions on Ch. One by calling sudo ls and then putting in my password.

  • Seth here. Hello. I uncommented the line in the file grub GRUB_HIDDEN_TIMEOUT=0, i.e. I put a # in front of the line. I rebooted and nothing happened. I changed the timeout value and nothing happened. I am not sure what to do from here.

  • Hello...https://www.linux.com/forums/lfs201-class-forum/lab-31-booting-non-graphical-mode-using-grub-ubuntu-1610​ is similar to my issue. I tried to change the file grub and then reboot. This did not work. I can press Esc over and over again to get into GRUB, though. Should I change my GRUB file in SSH via /etc/default or in the GRUB screen?

  • silver2rowsilver2row Posts: 29
    edited February 2017

     

    Hello Once More...Seth here. I appended "text" and/or "3" to the line that starts with Linux and pressed Control-X. I booted into Graphical Mode still. I changed the lines in the GRUB file in SSH to "#" respectively. I updated GRUB by sudo update-grub. I also rebooted. I came to the GRUB screen like described. I pressed "e" and I was brought to the screen to edit my GRUB in basic mode. I cannot figure out what to do. I am sorry. The system still boots in Graphical Mode.

     

  • coopcoop Posts: 339
    edited February 2017

    In my initial post I forggot to say "sudo update-grub" after you edit /etc/default/grub (thanks for the other poster who did do this)  Otherwise editing the file is ineffective.  Furthermore to edit the file you have to be superurser, do you have to do something like "sudo vi /etc/default/grub"  (or use emacs, nano, gedit instead of vi)

    If you want to make booting into command line first a permanent behaviour, edit the line "GRUB_COMDLINE_LINUX=" and add the option at the end (" 3")

     

  • silver2rowsilver2row Posts: 29
    edited February 2017

    Hello...I got the system to work. The username and password section to sign in on text mode worked finally. I had to put a 3 behind the end of that GRUB_COMDLINE_LINUX=... Thank you. I saved it and got in to text mode.

Sign In or Register to comment.