Issue with Lab 4.2
I'm having an issue on 4.2 lab with what I thought would be a simple example for setting up a service with systemd
I'm running CentOS Linux release 7.3.1611 (Core)
[student@dolphin ~]$ sudo cat /etc/systemd/system/fake2.service
[Unit]
Description=fake2
After=network.target
[Service]
ExecStart=/bin/sh -c ’/bin/echo I am starting the fake2 service ; /bin/sleep 30’
ExecStop=/bin/echo I am stopping the fake2 service
[Install]
WantedBy=multi-user.target
student@dolphin ~]$ sudo systemctl start fake2.service
Failed to start fake2.service: Unit is not loaded properly: Invalid argument.
See system logs and 'systemctl status fake2.service' for details.
[student@dolphin ~]$ sudo systemctl -l status fake2.service
● fake2.service - fake2
Loaded: error (Reason: Invalid argument)
Active: failed (Result: exit-code) since Mon 2017-02-13 10:27:39 EST; 3min 42s ago
Main PID: 4068 (code=exited, status=127)
Feb 13 10:27:39 dolphin.localdomain sh[4068]: I: ’/usr/bin/echo: No such file or directory
Feb 13 10:27:39 dolphin.localdomain systemd[1]: fake2.service: main process exited, code=exited, status=127/n/a
Feb 13 10:27:39 dolphin.localdomain systemd[1]: Failed to start fake2.
Feb 13 10:27:39 dolphin.localdomain systemd[1]: Unit fake2.service entered failed state.
Feb 13 10:27:39 dolphin.localdomain systemd[1]: fake2.service failed.
Feb 13 10:29:21 dolphin.localdomain systemd[1]: [/etc/systemd/system/fake2.service:6] Trailing garbage, ignoring.
Feb 13 10:29:21 dolphin.localdomain systemd[1]: fake2.service has no ExecStart= setting, which is only allowed for RemainAfterExit=yes services. Refusing.
Feb 13 10:30:05 dolphin.localdomain systemd[1]: [/etc/systemd/system/fake2.service:6] Trailing garbage, ignoring.
Feb 13 10:30:05 dolphin.localdomain systemd[1]: fake2.service has no ExecStart= setting, which is only allowed for RemainAfterExit=yes services. Refusing.
Feb 13 10:31:08 dolphin.localdomain systemd[1]: fake2.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.
Comments
-
Hey I ran the fake2.service configuration you posted (copy and pasted from above) and got a different error. I had to replace the single quotes around the Execstart parameters surrounding the echo command.
I made the following change:
OLD
[Unit]
Description=fake2
After=network.target[Service]
ExecStart=/bin/sh -c ’/bin/echo I am starting the fake2 service ; /bin/sleep 30’
ExecStop=/bin/echo I am stopping the fake2 service[Install]
WantedBy=multi-user.targetNEW
[Unit]
Description=fake2
After=network.target[Service]
ExecStart=/bin/sh -c '/bin/echo I am starting the fake2 service ; /bin/sleep 30'
ExecStop=/bin/echo I am stopping the fake2 service[Install]
WantedBy=multi-user.targetI don't know if it will resolve your issue. I hope this helps.
0 -
Thanks, that was the issue!
0 -
Nice, no problem.
0 -
Hi,
That's weird; so, you replaced the single quotes by hand, right? Did you copy and paste the command from the pdf file? There may be something with the formatting.
0 -
Hey,
It is weird; by hand? As opposed to using sed or something else?
I didn't look at the pdf. I just read rcmills post then copied and pasted the configuration for their service. I assumed that rcmills hand wrote the configuration since he/she also used the name 'fake2' instead of 'fake_service' (I think thats what the pdf used).. but they could have pulled it from the pdf themself and pasted it into an editor that altered the quotes too.
Regardless, quotes are not used anywhere else in the configuration so I also assumed they used an editor other than vi or emacs--- likely an ascii code difference between open/closed quotes and straight quotes? I didn't look into it any further. Once I ran the service I just looked at the log and changed the line; it worked.
Whoops- streamline thinking a bit. I'll look at the pdf later and see if there are any issues on my system similar to this problem.
0 -
cutting and pasting from pdf's or html often screws up single quotes fro some reason
0
Categories
- All Categories
- 178 LFX Mentorship
- 178 LFX Mentorship: Linux Kernel
- 774 Linux Foundation IT Professional Programs
- 383 Cloud Engineer IT Professional Program
- 175 Advanced Cloud Engineer IT Professional Program
- 75 DevOps IT Professional Program - Discontinued
- 7 DevOps & GitOps IT Professional Program
- 103 Cloud Native Developer IT Professional Program
- 7.6K Training Courses & Learning Paths
- 11 AI & ML Training
- 1 Blockchain & Decentralized Identity Training
- 32 Cloud & Containers Training
- 3 Cybersecurity Training
- 2 DevOps & Site-Reliability Training
- 1 Linux Kernel Development Training
- 2 Networking Training
- 2 Open Source Best Practice Training
- 5 System Administration Training
- 1 System Engineering Training
- 4 Web & Application Development Training
- 798 Hardware
- 202 Drivers
- 68 I/O Devices
- 37 Monitors
- 96 Multimedia
- 173 Networking
- 91 Printers & Scanners
- 92 Storage
- 772 Linux Distributions
- 81 Debian
- 68 Fedora
- 24 Linux Mint
- 13 Mageia
- 24 openSUSE
- 151 Red Hat Enterprise
- 31 Slackware
- 13 SUSE Enterprise
- 356 Ubuntu
- 469 Linux System Administration
- 31 Cloud Computing
- 73 Command Line/Scripting
- Github systems admin projects
- 101 Linux Security
- 79 Network Management
- 101 System Management
- 46 Web Management
- 160 Mobile Computing
- 29 Android
- 116 Development
- 1.2K New to Linux
- 1K Getting Started with Linux
- 405 Off Topic
- 127 Introductions
- 34 Study Material
- 1K Programming and Development
- 310 Kernel Development
- 718 Software Development
- 1K Software
- 418 Applications
- 182 Command Line
- 5 Compiling/Installing
- 71 Games
- 320 Installation
- Archived
- 183 Small Talk
- 2 LFD140 Class Forum
- 1.4K LFS258 Class Forum
Upcoming Training
-
August 20, 2018
Kubernetes Administration (LFS458)
-
August 20, 2018
Linux System Administration (LFS301)
-
August 27, 2018
Open Source Virtualization (LFS462)
-
August 27, 2018
Linux Kernel Debugging and Security (LFD440)
