Welcome to the new Linux Foundation Forum!

Possible error in Lab 81.

adamherstadamherst Posts: 25
edited January 2017 in LFS211 Class Forum

The solution didn't work for me on Ubuntu. In step 2, should the line:

ScriptAlias /scripts/ /new-cgi/

be:

ScriptAlias /scripts/ /full/path/to/new-cgi/

as per the Apache doc:

ScriptAlias [URL-path] file-path|directory-path

which did work for me?

Comments

  • lee42xlee42x Posts: 118
    edited January 2017

    Yes, you are correct, the full path name is to be used. 

    I will revisit the instructions for the lab, but the intention was the fully qualified path name to used in the lab was to be "/new-cgi". 

  • PipoPipo Posts: 1
    edited July 2017

    In my case the problem is that we have to run the following command in order to be able to execute the cgi script.

    chcon -R --reference=/var/www/cgi-bin /new-cgi/

  • lee42xlee42x Posts: 118
    edited August 2017

    Yes, you are correct, if SELinux is in enforcing mode you would require the correct context and the command you gave is perfect. A quickmethod to verify if SELinux is causing unexpected results is to place SELinux into "permissive" mode with the command:

    setenforce 0  

    then re-try the action.  Verify in the error log if SELinux identified and logged an error. The errorlog should also contain a "sealert" command to be run for addtional details. 



    I believe that the VM's available for running the class from the Linux Foundation have SELinux turned off and then enabled for specific lab exercises. If you installed fresh from the distro media some diftro's have SELinux on by default. Although using SELinux is excellent, sometimes it can detract from a specific learning objective. 

     

Sign In or Register to comment.