Welcome to the new Linux Foundation Forum!

Problems installing Epson L355 printer on Lubuntu 16.04

I have installed Lubuntu 16.04 and can not install my Epson printer L355, basically I tried two ways:

1. Downloaded from www.openprinting.org and installed the package: epson-inkjet-printer-201207w_1.0.0-1lsb3.2_i386.deb. Apparently it installed fine but when opening "Printers" window, although it appears "connected to localhost" there is a message "there are not printers configured yet" and pressing the "add" button it asks for an "URI code", for me it does not look as the right path. In fact, this PC ran on Lubuntu 14.04 for two years and at that time it was pretty easy to configure just the same printer.

2. Using the terminal I have installed "cups-2.2rc1" package. Then tried the browser to go to "http://localhost:631" and the answer was: "not found - CUPSv2.1.3" I wonder, Could this be a Firewall issue? I am conected to internet thought a router without proxy.

Two more details: One, before step 1 using the terminal I installed the LSB3.2 package, and two: it is not a hardware issue, in fact I can scan without problem with "Simple Scan" and as I mentioned it worked fine on Lubuntu 14.04.

My wife and I will be very grateful of your help as we depend on printing for our daily work.

Greetings and thanks

Comments

  • saqman2060saqman2060 Posts: 777
    edited August 2016

    I am not an expect at configuring printers on Linux. Linux has still a mountain to climb trying to get this procedure to work flawlessly. If your printer worked fine on ubuntu 14.04, then I would revert back to it. Then create a separate install of 16.04 and try to configure your printer from there. This way, you can still get work done while tinker with 16.04.

    You sound like you know what you are doing. Put 16.04 in a sand box and hack away. Nothing ever works as they seem from after an upgrade.

Sign In or Register to comment.