Welcome to the new Linux Foundation Forum!

Data Recovery After Failed Xubutu 16.04 Update

Hi -

Apologies if this is the wrong forum, I've just registered. I'm at the end of my rope trying to figure out how to recover my data after a failed Xubuntu 16.04 LTS update.

I ran Xubuntu 15.04 LTS on an old Samsung Netbook and used it as a file storage / home plex server. During the update to 16.04 the system became unresponsive and I restarted the computer (obviously, should not have done that). After that, I could not log into the system: the new version didn't show up in the list of installed ubuntu versions and the old version wouldn't load.

I booted up from a live usb and managed to mount the drive with the messed up system. I could navigate to the /home and /home/MyUserName folder but that is encrypted and says I don't the privileges to access the files.

I tried using ecrypt per what I managed to find googling but to no avail.

Is there any way I can restore my data? It 100+ Gb of family photos taken over a couple of years...

Tons of thanks in advance!

P.S. I am fairly new to Linux so don't really know much about the system.

 

 

 

 

 

 

Comments

  • Newbie2LinuxNewbie2Linux Posts: 5
    edited August 2016

    Many thanks arochester but this is too easy and generic. As you can see from my original post, I can mount the disk and navigate it but my /home/UserName folder is encrypted and it says I don't access privileges to see the files. I need to find a way to get the permissions to view the files.

    Thanks!

  • arochesterarochester Posts: 288
    edited August 2016

    "I could not log into the system"

    What does this mean? What happened? What do you see?

    Could you get out of grapical mode and into text mode by pressing Alt+Ctrl+F1  ?

    If you can you can try

    sudo apt-get update

    sudo apt-get upgrade

    sudo apt-get dist-upgrade

     

  • 1. Ran Xubuntu 15.04 on Samsung Netbook

    2. Initiated update to 16.04

    3. During upgrade the system froze

    4. Restarted the machine

    5. After restart, could see the window which allows to select the version of Xubutu to run

    6. 16.04 not listed

    7. Chose the version that was previously installed (15.04)

    8. The system would initiate, show the Xubutu logo and freeze thereafter, no matter what you do

    9. Boot from Live USB

    10. Can see, mount and navigate the files on the hard drive

    11. Navigate to /home directory

    12. Go to my folder within /home where all my files are located

    13. See Access-Your-Private-Data.desktop and README.txt

    14. Try this http://www.howtogeek.com/116297/how-to-recover-an-encrypted-home-directory-on-ubuntu/

    15. However, I get "Encryption is not set up" instead

     

     

     

  • arochesterarochester Posts: 288
    edited August 2016

    Without th USB

    From #8 press Alt+Ctrl+F1

    Does it change?

  • Newbie2LinuxNewbie2Linux Posts: 5
    edited August 2016

    No. The grub window doesn't change.

  • arochesterarochester Posts: 288
    edited August 2016

    Can you  remove the splash screen so it boots in text mode rather then graphical mode? Can you use your USB to navigate the the Hard Drive file /boot/grub/menu.lst?

    If you can scroll to the bottom of that file you should see a line including "splash". Can you remove the word splash from the line and restart your computer?

  • Strange, I can't locate the file. (I should have it given I can get to the grub window without the live usb.) Any thoughts?

Sign In or Register to comment.