Welcome to the Linux Foundation Forum!

No distro of linux will install.


Ok so to get to the main point I can not get any distro to work. I've tried many methods, many months researching and just nothing works. I've read it was a problem with my Mobo and that people can only really get windows to work on it. I've tried installing very common distros, like Mint and Ubuntu, to uncommon ones like Chromixium(originally downloaded for my mother).


My motherboard is a Gigabyte 970A-UD3P rev.1; I've read of very few success stories but none of the methods worked for me. I've even tried installing it via a laptop which could install linux. Install went fine, but once I put the SSD back into my desktop, I never got to the login screen it just stopped before I could log in. I have the latest BIOS, I've tried UEFI and legacy, and legacy gets me through the setup, but once it should start installing it just stops. I've tried Enabling/Disabling IOMMU, which is said to work, yet nothing. I'm ready to be content with Windows because I am at my wits end.


  • dday35216
    dday35216 Posts: 71

    At this point, I might look into another mobo.



Upcoming Training