Welcome to the new Linux Foundation Forum!

Enter Password for Default Keyring to Unlock

Hi,

I'm using Ubuntu 10.10 and I would like to know a way to know what applications are asking you to enter password for default keyring to unlock.

In the past that dialog used to appear at startup once but now appears twice and I would like to know which applications are asking me for the password. Is there any log where I can see it?

Thank you in advance.

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    You might want to start by telling us where you see these requests for passwords. Passwords are asked for when root privileges are needed.
  • You might want to start by telling us where you see these requests for passwords. Passwords are asked for when root privileges are needed.

    Thank you for your answer. I get these requests on startup, when ubuntu finishes loading.
    Any ideas?
    Any hep will be appreciated.
  • OK, gnome-keying is an application that allows you to setup an encrypted password to access certain applications of devices where you confirm that you are the rightful owner. I have the same thing setup on some of my ubuntu systems on my network. Usually your password is your username or an old username that previously used.

    Foe me my keyring prompts when I have to connect to a wireless router. Are you connected to a Wireless router? Check /var/logs to see what recently happened.
  • Thank you for the answer.
    In auth.log I can see this reagrding to my current session:
    Jan  2 14:42:47 josep-laptop gdm-session-worker[1343]: pam_unix(gdm-autologin:session): session opened for user josep by (uid=0)
    Jan  2 14:42:47 josep-laptop gdm-session-worker[1343]: pam_ck_connector(gdm-autologin:session): nox11 mode, ignoring PAM_TTY :0
    Jan  2 14:42:50 josep-laptop pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
    Jan  2 14:42:50 josep-laptop pkexec: pam_ck_connector(polkit-1:session): cannot determine display-device
    Jan  2 14:42:50 josep-laptop pkexec[1492]: josep: Executing command [USER=root] [TTY=unknown] [CWD=/home/josep] [COMMAND=/usr/sbin/gnome-power-backlight-helper --set-brightness 7]
    Jan  2 14:42:50 josep-laptop polkitd(authority=local): Registered Authentication Agent for session /org/freedesktop/ConsoleKit/Session1 (system bus name :1.25 [/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.utf8)
    Jan  2 14:42:51 josep-laptop dbus-daemon: [system] Rejected send message, 1 matched rules; type="method_return", sender=":1.11" (uid=0 pid=1229 comm="/usr/sbin/bluetoothd) interface="(unset)" member="(unset)" error name="(unset)" requested_reply=0 destination=":1.30" (uid=1000 pid=1512 comm="bluetooth-applet))
    Jan  2 14:42:52 josep-laptop dbus-daemon: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.39" (uid=1000 pid=1503 comm="nautilus) interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply=0 destination=":1.6" (uid=0 pid=950 comm="/usr/sbin/console-kit-daemon))
    Jan  2 14:42:54 josep-laptop gnome-keyring-daemon[1402]: unsupported key algorithm in certificate: 1.2.840.10045.2.1
    Jan  2 14:42:55 josep-laptop gnome-keyring-daemon[1402]: unsupported key algorithm in certificate: 1.2.840.10045.2.1
    
    

    However I don't figure out what applications are asking me for the password. It seems to me that nautilus is asking for the password but I don't use it so I'm not totally sure.
    Can you tell me what applications are asking me for the password to unlock the keyring?

    Thank you in advance
  • The application that's asking for authentication are the names after josep-laptop.

    It looks like gnome-keyring executes after the system runs the dbus-daemon. From the log, dbus is attempting to connect to something and the session is being rejected. Then thats when keyring executes. Did you configure dbus for something.s?
    I think you are connecting to something using bluetooth. What is it?
  • It looks like gnome-keyring executes after the system runs the dbus-daemon. From the log, dbus is attempting to connect to something and the session is being rejected. Then thats when keyring executes. Did you configure dbus for something.s?
    I think you are connecting to something using bluetooth. What is it?

    Thank you very much.
    I don't use bluetooth but it was connected. I've disabled bliuetooth (I've disconnected de device) but I still get a prompt at startup.
    Now I get this on the log:
    Jan  2 21:55:07 josep-laptop gdm-session-worker[1303]: pam_unix(gdm-autologin:session): session opened for user josep by (uid=0)
    Jan  2 21:55:07 josep-laptop gdm-session-worker[1303]: pam_ck_connector(gdm-autologin:session): nox11 mode, ignoring PAM_TTY :0
    Jan  2 21:55:10 josep-laptop polkitd(authority=local): Registered Authentication Agent for session /org/freedesktop/ConsoleKit/Session1 (system bus name :1.23 [/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.utf8)
    Jan  2 21:55:10 josep-laptop pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
    Jan  2 21:55:10 josep-laptop pkexec: pam_ck_connector(polkit-1:session): cannot determine display-device
    Jan  2 21:55:10 josep-laptop pkexec[1540]: josep: Executing command [USER=root] [TTY=unknown] [CWD=/home/josep] [COMMAND=/usr/sbin/gnome-power-backlight-helper --set-brightness 7]
    Jan  2 21:55:12 josep-laptop dbus-daemon: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.32" (uid=1000 pid=1520 comm="nautilus) interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply=0 destination=":1.8" (uid=0 pid=1023 comm="/usr/sbin/console-kit-daemon))
    Jan  2 21:55:14 josep-laptop gnome-keyring-daemon[1433]: unsupported key algorithm in certificate: 1.2.840.10045.2.1
    

    Any ideas?

    Thank you.
  • Yes, your are encrypting your profile. Since you are using gnome, go to systems>preferences> startup windows. Once in the dialog box, de-select gnome-keyring from running during startup.
  • Yes, your are encrypting your profile. Since you are using gnome, go to systems>preferences> startup windows. Once in the dialog box, de-select gnome-keyring from running during startup.

    Thank you!
    However I've deselected it and there is still a message for unlocking keyring at startup :unsure:

    Any ideas?
  • I am guessing your account does not have exclusive system rights. Since you are using ubuntu, there is a system group named "sudo". Go to that group, click properties, and select your username. Restart the system
    Once you are part of the "sudo" group, you should no longer see the keyring program run. It will think you are part of the root.

    Hope this helps.
  • Hi,
    I'm sorry for the delay. I've been very busy these days.
    I've finally came across the same problem. Thank you for your ideas.
    I got rid of this problem two ways. First, Playing under "Users and Groups" and secondly deleting some of the password (mainly that were saved in Empathy) entries from "Passwords and Encryption Keys". I may not remember all the details, but now although I have my root/user passwords intact, I don't have that annoying "Default" password notification at boot up.
Sign In or Register to comment.