Welcome to the Linux Foundation Forum!

Having Trouble With Sudoer List...

Hey guys,

I just downloaded Fedora after having some problems with Ubuntu and noticed that i cannot just use the sudo command anymore. It says my user is not on the sudoer list. I use the visudo command but was not sure on what exactly needed to be put down.

My username is Sudo if that helps.

Thanks a lot,

Carson M

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    If you go to:
    System-->Administration-->Users and Groups
    Then go to:
    Edit-->Preferences and uncheck "Hide System Users and Groups". Sudo is a User group, so, if it's there it will show up, but, I like to see something other than a blank screen when I'm adding groups.
    Then close that window and go back to the User Manager.

    Click on Add group, type in sudo, check the box so it automatically assigns a user number. Hit OK, then:
    Click on Groups, then double click on sudo to bring up Group Properties. Check off your user name, and then exit Users and Groups and you should be good to go.

    There's probable and easier way to do it trough the terminal, but, it's easier to step you though it (for me anyway) this way.

    BTW - I can't believe Fedora made it this hard, and also, why wasn't sudo placed in the groups to start off with, it seems to be installed by default. Fedora is my current distro, but sometimes the decisions they make aren't that user friendly and seem to point towards enterprise use (well, Red Hat does come from Fedora). Sudo group should be there, then, you should just have to add it to the user. Oh, well, I hope this helped. If it didn't, let me know. I'm still working on my first coffee.

    Edit: You username is Sudo? That could be confusing, but to each his/her own.
  • Thanks a lot Goineasy9 ,
    That worked perfectly. I thought when i first registered my guest it would allow me root privileges which i thought included those of sudo. Anyways, are there any programs you recommend to me for Fedora?
    Thanks Again,
    Carson M
  • Goineasy9Goineasy9 Posts: 1,116
    I actually started to write a blog about setting up Fedora, but, never had the time to finish it. Maybe I'll try again this weekend. Until then, some hints to start off with.

    In /boot/grub/grub.conf, using an editor as root, change the timeout from 0 to 3, and, put a hash mark in front of hiddenmenu (#hiddenmenu). This will give you the ability to see the grub menu as you're booting up.

    yum install alacarte - gives you the ability to edit menus in Fedora.

    yum install mesa-dri-drivers-experimental - if you have a Nvidia graphics card and want 3D and improved graphics (without having to use the proprietary driver).

    I've used Autoten for installing codecs, flash and other non-free apps that still are needed. Link:
    http://dnmouse.org/forum/viewtopic.php?f=2&t=105&sid=cc4845537df827830b6787f83f87d2b8

    yum install padevchooser paman pavucontrol paprefs - since Fedora loves Pulseaudio, these utilities make it easier to manage.

    You can enable rpmfusion repos here:
    http://rpmfusion.org/Configuration - This is where the proprietary drivers for video, wifi etc., are kept.

    These are just a few of the many things I do/add when I set up a new Fedora install. If you have any more questions, feel free to ask. You can even start new threads in the Fedora section of the forum, which may help others who have similar questions.
  • Wow,
    All those are helpful so thanks again. A blog on Fedora would be amazing i think. Keep up the good
    work.
    Carson M
  • roobalroobal Posts: 25
    In Fedora, you can use su command to log in as root.
Sign In or Register to comment.