Welcome to the new Linux Foundation Forum!

New user blues

Been using Debian KDE 3.5 for about two years, and have had a pretty good time of it until lately. I have Comcast as an ISP and Firefox as a browser. Over the last two months, I have had frequent Internet crashes; Firefox 'can't find server' and for the last three days it has been out more than it's in. Comcast swears it's not their fault. Inquiries to Firefox have not yet received answers. So: is there a more Linux-compatible ISP than Comcast, or a better browser than Firefox? I know the head of our local LUG doesn't like Ff at all.

Also, I feel like a real fraud, because I really don't know a lot about computers, and when I tell people I use Linux, they assume I'm very computer literate.

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    Usually when Firefox "can't find server", it's usually your network and not firefox per se. Although firefox has it's problems (crashing, memory leaks etc.) it's usually very stable. I use it daily and give it quite a workout.
    Maybe you can tell us more about your setup. What distro your using, hardware etc. Are you using a router with a comcast cable modem? Is it the only computer using the connection? Are you using wireless or wired? And/or anything else that might be unique to your setup.
    And, heh, if your using Linux, even as a newbie, your probably more computer literate than most windows users . :-P
  • Debian KDE 3.5, cable modem, connected through Vonage box. HP CPU, loaded up at computer show. Cable modem is Motorola SB5101 All wired.
    There's a lot of basic computer stuff I don't know, especially for Linux. I downloaded Firefox 3.5.2, but it didn't install; just sitting on my desktop. Where do I find the install/uninstall control panel? If that's what I need to do the job
  • mfillpotmfillpot Posts: 2,180
    you should see a program called something like package manager in your administrative seettings menu to install the new version of firefox. Please be aware that using debian or a debian based distro you don't need to download hte program from the firefox website, the package manager can download, install and configure from an online repo.

    Next time you get the issues go to the terminal and try to ping the website to see if the address as resolved or if you have connectivity.
  • Thanks. :)
  • woboylewoboyle Posts: 501
    I have usually found that this is because the ISP's DNS servers are fubar. To check that, I change my default dns server address to one of the top-level servers on the internet. Contact me by personal message and I'll give you a couple of those IP addresses.
  • MMcQuownMMcQuown Posts: 12
    I got to the package manager, but couldn't find anything that seemed right. Mostly what I seem to be getting is options to uninstall existing software. I also can't find plug-ins for video. If I can get my Ff browser update and a good video plug-in, I should be good to go.
  • Hi!

    You can help us help you by telling us which Debian you are using (Lenny, Squeeze, Sid, etc). The Debian version of Firefox is called Iceweasel, not Firefox (same software, different branding). Using Synaptic to install software is always safer and easier than downloading from a web site!

    Some people have better luck with one network manager over another, too. Debian's Knetwork manager (the KDE one) didn't work as well on my 'puter as a different one called "Wicd." Installable from Synaptic, it offered a little better connectivity for me than before (your mileage may vary).

    Robin
  • MMcQuownMMcQuown Posts: 12
    Now using Ubuntu 7.10. Getting synaptic package manager, but I am seeing only options for uninstalling packages, not installing them. Also keep getting messages to install plug-ins for videos, but when I try to find them, says 'no plug-ins found.' Very frustrating.
  • mfillpotmfillpot Posts: 2,180
    Why did you choose to install a 2 1/2 year old (5 releases ago) version of ubuntu that has not been updated since last year? that is probably the reason why you can't connect to the repos, additionally that version is open to many security exploits and is not advised to be run without all patches.

    I highly recommend installing ubuntu 9.04 or 9.10 to you are using a currently supported version. So you know the ubuntu version numbers relate to the year and month of the release, so 9.04 means it was released in 2009 in the 4th month, your version was released in October 2007.
  • MMcQuownMMcQuown Posts: 12
    I used it because I had it. After my other machine broke down, I eventually got another one, tired to run it with my old hard drive, which contained the Debian KDE 3.5, and it didn't work. It got me into the opening sequences, took me to user name and password. ONce I entered that, it sat, apparently wanting some sort of command. When I tried using some of the few shell commands I knew, it didn't respond, and once I got a message that said something to the effect that the command dictionary wasn't installed. So, I had a clean hard drive and the Ubuntu disk, so I set that up and at least got back online, and a good thing, too, as I had missed a very important e-mail.
    I tried to upgrade online, which didn't work, When I started, it said about 22 hours to complete, but 36 hours later, it was still running the upgrade, with no indication that it would ever complete. I did order an upgraded disk, but it hasn't come yet. The new computer is a rebuild with a Pentium 4 processor, but it's a flatbox model with no space for a second hard drive for a master/slave config. I am very broke, so I don't have a lot of choices about what I can get, which is why I appreciate the help I get here so much.
  • mfillpotmfillpot Posts: 2,180
    That is ok, If you have a working machine you can download the latest iso file for the latest version of ubuntu 9.10 for free (http://www.ubuntu.com/getubuntu/download) and burn it to a CD yourself. Once it is on a CD you can easily install the latest version. If you read around on the site, you can also find instructions for installing for a USB drive.
  • MMcQuownMMcQuown Posts: 12
    This machine doesn't have a read/write CD; just a read. I can upgrade in a couple of weeks, but not just yet. In the meantime, I have ordered the upgrade disc anyway, so it may be a case of which arrives first
    One of the reasons I got into Linux was because it seems to be safe from all the crap that attacks Windows. Is this true, or am I deluding myself? Trouble is, I really feel out of my depth, because there is a lot I don't know about basic computer.
  • mfillpotmfillpot Posts: 2,180
    MMcQuown wrote:
    This machine doesn't have a read/write CD; just a read. I can upgrade in a couple of weeks, but not just yet. In the meantime, I have ordered the upgrade disc anyway, so it may be a case of which arrives first
    One of the reasons I got into Linux was because it seems to be safe from all the crap that attacks Windows. Is this true, or am I deluding myself? Trouble is, I really feel out of my depth, because there is a lot I don't know about basic computer.

    You can still attmpt a usb based installation if that system is able to boot from a usb flash drive.

    To answer your question, Linux based systems do a lot more self cleaning than windows and they are less open to viri and spyware, the reason for the near lack or viri and spyware is that it uses a better security model in relation to user rights.
    Basically by running a Linux system and doing your homework you will not have to worry about or look for:
    Viruses
    Spyware
    Disk Cleanup
    Defragmentation
    Firewall
    Most Hardware drivers
    most print drivers
    and which websites you visit
  • vtel57vtel57 Posts: 164
    Hi Michael!

    Welcome to Linux.com and to your new Linux Adventure. As a new Linux Explorer (I don't like to use the word "newbie"), you'll be learning LOTS of goodies in the next few months. Don't get frustrated and give up. It's well worth the effort. I was a 100% MS Windows user up until the summer of '06. I converted to the GNU/Linux operating system at that time and never looked back.

    One thing I always tell all new Linux Explorers whom I run across, "Linux is NOT MS Windows." Don't expect it to be. Linux is an entirely different operating system. You'll have a bit of a learning curve, just as you did when you first started using MS Windows. Expect frustrations and the occasional set back. They happen. Learn from the experience and move on.

    The second thing I always tell new Linux Explorers is to KEEP a notebook. It will save your rear echelon one of these days. You can't remember everything. Believe me when I tell you this. You can read about my note-taking habits here --> The Importance of Keeping Notes.

    And the last bit of info I pass along to new Linux Explorers is usually a series of links. Bookmark these. They're some of the best. Linux has one of the largest communities on the Internet. 99% of the folks in those communities will do all the can to assist you. It's all out there for the asking. Keep something in mind, though... you'll be more respected as a seeker of assistance if you show some previous effort on your part to research answers on your own. Google is your friend. No one likes the type of poster who shows up at a support site and asks to have all things spoon fed to them.

    Helpful links:

    Linux.com

    Linux Compatibility

    Distrowatch

    The Linux Documentation Project

    Linux Wikipedia article

    Tips for Linux Explorers

    YoLinux! Tutorials

    Scot's Newsletter Forums - Bruno's All Things Linux

    Linux Questions.org

    And remember... have FUN with it! :)

    Regards,

    ~Eric
  • Thanks to all for your input and help. Now on Ubuntu 10.04, which is loads better.
    I have two systems, one of which locked up on an update, and is absolutely stuck. The cursor won't move, and is resting in its I form in the middle of an error window. Nothing responds. On my box system (rebuilt Compaq Evo) I have had occasional boot-up problems with an error message about an add-in card. Whazzat all about?
  • mfillpotmfillpot Posts: 2,180
    Are both of the system with errors running ubuntu 10.04?
Sign In or Register to comment.