Welcome to the Linux Foundation Forum!

ssh - execute the script remotely / File not found

ssh - execute the script remotely / File not found: ''

I am uisng amazon ec2-api-tool & ec2-ami-tool

i was unable to execute through ssh.

Getting error as

File not found: ''

The same script i can able to run directly in client machine successfully.

Through ssh i was uanble to run the script remotely

Source : myScript.sh

ec2-create-volume --size $1 --availability-zone $2

$ssh -i key.pem [email protected] ./myScript.sh 10 us-east-1a

File not found: ''

Note:

i have read write permission to my remote machine script myScript.sh

What i might have done mistake...?

Comments

  • mfillpot
    mfillpot Posts: 2,180
    You must point to the absolute position of the script on the remote machine. Currently your ssh call is looking in the root directory for your script.
  • cloudsuser
    cloudsuser Posts: 7
    As you said i treid with following command,

    $ssh -i key.pem [email protected]<host> -C /root/myScript.sh
    Output: File not found: ''

    In remote machine, $ls -rtl myScript.sh
    $-rwxr--r-- 1 root root 59 May 30 12:31 myScript.sh

    Source: myScript.sh
    ec2-create-volume --size 10 --availability-zone us-east-1a

    Note: I can able to manually execute the command "ec2-create-volume --size 10 --availability-zone us-east-1a" successfully
    If i want to execute the same with ssh via script, how i should procede. Please help me on this.
  • mfillpot
    mfillpot Posts: 2,180
    ssh -i key.pem [email protected]<host> -C "sh /root/myScript.sh <args>"
  • jabirali
    jabirali Posts: 157
    I think mfilpot is right, you need to explain to your system how to run your script. An alternative to specifying the interpreter when you invoke the script, is to define the interpreter in the beginning of the script itself, like this:
    #!/bin/sh
    ec2-create-volume --size 10 --availability-zone us-east-1a
    
    If you do this, I think your command should work fine:
    ssh -i key.pem [email protected]<host> -C /root/myScript.sh
    
  • mfillpot
    mfillpot Posts: 2,180
    jabirali wrote:
    I think mfilpot is right, you need to explain to your system how to run your script. An alternative to specifying the interpreter when you invoke the script, is to define the interpreter in the beginning of the script itself, like this:
    #!/bin/sh
    ec2-create-volume --size 10 --availability-zone us-east-1a
    
    If you do this, I think your command should work fine:
    ssh -i key.pem [email protected]<host> -C /root/myScript.sh
    

    I also want to note that if you are planning to add input arguments you may want to enclose the script path and arguments in quotes, although it can work without the quotes depending on the arguments.
  • cloudsuser
    cloudsuser Posts: 7
    As you said i tried with following option,

    1) added "#!/bin/sh" in myScript.sh

    ssh -i key.pem [email protected]<host> -C "sh /root/myScript.sh"
    [color=]Output: File not found: ''[/color]


    2) $ssh -i key.pem [email protected]<host> -C "/bin/sh ec2-create-volume --size 10 --availability-zone us-east-1a"
    Output: File not found: ''
  • mfillpot
    mfillpot Posts: 2,180
    1. If you script is in the location specified then maybe ssh is not finding the specified key, either way one of the files cannot be located.

    2. if ec2-create-volume is a command in $PATH then you do not need to call /bin/sh to execute it

    I am leaning on the system not finding the key file that you are specifying because both command are reporting the same error.
  • cloudsuser
    cloudsuser Posts: 7
    Thanks for your info.

    Please note ,

    1) The key is available. I can able to ssh(login) successfully with the help of key
    2) ec2-create-volume is a command in $PATH

    What may be the issues ?
  • mfillpot
    mfillpot Posts: 2,180
    Everything seems like it should work, the only things I can think of now would be if some option is blocking you from executing scripts on the remote machine or if the user's ssh access is chrooted.
  • gomer
    gomer Posts: 158
    Have you tried running ec2-create-volume with the full path included? I know you said it's in $PATH, but give it a whirl. I'm curious if that will work.
  • rfelsburg
    rfelsburg Posts: 1
    So just for some clarification:

    You are sshing from $HOST1 to $HOST2.

    Obviously, your keyless auth works, however, is the script located on $HOST1 or $HOST2.

    If the script isn't located on $HOST2 it won't work, once you've ssh'd over, any command you pass will be executed on $HOST2 not on $HOST1.


    -Rob
  • pbulteel
    pbulteel Posts: 2
    Another thing is that it's best practice to include the full path to the application your are running in your scripts.

    #!/bin/bash
    /path/to/ec2-create-volume --size 10 --availability-zone us-east-1a

    The error you're seeing is probably that it cannot find the ec2-create-volume application.

    If you're going to automate applications that are going to run remotely it's a good idea to define the environment variables you want for any script.

    you could create a env.sh which contains PATH, etc and in every script include it.

    #!/bin/bash
    source /root/env.sh
    /path/to/command

    Check exit codes to do anything if things go wrong, and return an exit code when your script finishes.

    By creating an env.sh that you can then incorporate it into all your scripts that you make afterwards and know that you've taken care of everything.

    --
    Patrick

Categories

Upcoming Training