Welcome to the Linux Foundation Forum!

Getting my printer to work again

jhaskins75
jhaskins75 Posts: 128

After I install Xsane scanner utility. my ability to access my printer ceased. I have a all in one brother printer, MFC240C. It was working previous to this program. I have completely removed xsane from my system and downloaded the proper drivers for my printer. After rebooting, my system recognized my printer, but it keeps saying it can not detect the drivers. I was given a series of commands to enter in my terminal before when this happened, but I have misplaced them. I know I was told that a certain order must be did for the driver download. I am not sure if it is the lpr first or the cups driver first. Please note, my printer is supported from linux via brother web download site.....HELP. Thank you, John:( :dry:

Comments

  • mfillpot
    mfillpot Posts: 2,177
    Since you found the commands and listed them on another post (http://www.linux.com/community/forums?func=view&catid=8&id=5265&limit=6&start=30#5328). I would like to remove this thread because it is essentially a duplicate.

    Please let me know if that is ok or if you wish to address other issues on this thread.
  • jhaskins75
    jhaskins75 Posts: 128
    [email protected]:~$ sudo apt-get install mfc240c
    [sudo] password for john822:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package mfc240c
    [email protected]:~$ sudo apt-get cache
    E: Invalid operation cache
    [email protected]:~$ /etc/apt/sources.list
    bash: /etc/apt/sources.list: Permission denied
    [email protected]:~$ sudo /etc/apt/sources.list
    sudo: /etc/apt/sources.list: command not found
    [email protected]:~$ echo /etc/apt/sources.list
    /etc/apt/sources.list
    [email protected]:~$ sudo apt-get install brother
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package brother
    [email protected]22-desktop:~$ apt-get install 1.01.1-1
    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
    [email protected]:~$ sudo apt-get install 1.0.1-1
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package 1.0.1-1
    [email protected]:~$ sudo dpkg-i --install
    sudo: dpkg-i: command not found
    [email protected]:~$ dpkg - i --install
    dpkg: need an action option

    Type dpkg --help for help about installing and deinstalling packages [*];
    Use `dselect' or `aptitude' for user-friendly package management;
    Type dpkg -Dhelp for a list of dpkg debug flag values;
    Type dpkg --force-help for a list of forcing options;
    Type dpkg-deb --help for help about manipulating *.deb files;
    Type dpkg --license for copyright license and lack of warranty (GNU GPL) [*].

    Options marked [*] produce a lot of output - pipe it through `less' or `more' !
    [email protected]:~$ dpkg - i --install all
    dpkg: need an action option

    Type dpkg --help for help about installing and deinstalling packages [*];
    Use `dselect' or `aptitude' for user-friendly package management;
    Type dpkg -Dhelp for a list of dpkg debug flag values;
    Type dpkg --force-help for a list of forcing options;
    Type dpkg-deb --help for help about manipulating *.deb files;
    Type dpkg --license for copyright license and lack of warranty (GNU GPL) [*].

    Options marked [*] produce a lot of output - pipe it through `less' or `more' !
    [email protected]:~$

    I just can't seem to do this at all!!!! You mention spaces in the correct order, and I tried mutiple combos

    if this was your problem how exactly would you write the command, in that way, I could copy and paste it in my terminal. before, the person actually downloaded those drivers to his system, then gave me the command to install....
    I
  • mfillpot
    mfillpot Posts: 2,177
    1. I do not know what mfc240c should be
    2. cache is not a package, whta are you trying to accomplish with this command?
    3. " /etc/apt/sources.list" - you are only referring toyour sourced file, to edit it you need to open it with a text editor.
    4. "echo /etc/apt/sources.list" - the echo command only repeats what you enter after it, the reply is valid. If you want to view the contents of the file you should use cat or less instead of echo.
    5. "sudo apt-get install brother" - there is no package called brother, so this will error out.

    i will not go over all commands because it looks a little to confused, can you please provide a link to the site that you got the instructions from so we can review the original instructions?
  • jhaskins75
    jhaskins75 Posts: 128
    The brother website is www.brother.com click download. My printer is the MFC-240C model All in one. You will be directed to the driver download page, as you will look for model MFC 240 C on the linux driver page....
  • mfillpot
    mfillpot Posts: 2,177
    The instructions on http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/instruction_prn1a.html are correct.

    where I put {download folder} you need to replace that with the folder name where the deb file were downloaded to.

    sudo dpkg -i {download folder}/mfc240clpr-1.0.1-1.i386.deb
    sudo dpkg -i {download folder}/mfc240ccupswrapper-1.0.1-1.i386.deb
    sudo dpkg -l | grep Brother
    Then proceed to step 5a to setup the print in cups.
  • jhaskins75
    jhaskins75 Posts: 128
    [email protected]:~$ sudo dpkg -i /mfc240clpr-1.0.1-1.i386.deb
    [sudo] password for john822:
    dpkg: error processing /mfc240clpr-1.0.1-1.i386.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    /mfc240clpr-1.0.1-1.i386.deb
    [email protected]:~$ sudo dpkg -l | grep Brother
    ii brmfcfaxcups 1.0.0-2 Brother MFC/FAX fax share function driver
    ii brmfcfaxlpd 1.0.0-2 Brother MFC-FAX LPD driver
    ii mfc240ccupswrapper 1.0.1-1 Brother CUPS Inkjet Printer Definitions
    ii mfc240clpr 1.0.1-1 Brother lpr Inkjet Printer Definitions

    As you can see, your instruction for part one failed, but the 'grep' worked.
  • jhaskins75
    jhaskins75 Posts: 128
    I have essentially given up. I have done everything asked of me. I know that my installer sent the package to synaptic and I updated it and it shows and I entered the precise command from brother web page and I think that everything taken into account. The hang up is ' name of download folder ' which is in my Home folder ' john822, and when I open it, it does not show the mfc downloads. The only way to view them is, if I save them to my home folder, then I can view them in my download folder. And brother instruction for their command to force all, shows on the end of the command { lpr-drivername}
    I will assume I am not that stupid to say the driver name, at lease to me is: mfc240clpr-1.0.1-1.i386.deb and mfc240ccupswrapper-1.0.1-1.i386.deb I will also assume that my folder name will be john822, if that be a destination, then you guys tell me what the folder name is. Here is what I finally attempted to do by strict [email protected]:~$ sudo dpkg -i --force-all
    lpr-mfc240clpr-1.0.1-1.i386.deb
    [sudo] password for john822:
    Sorry, try again.
    [sudo] password for john822:
    Sorry, try again.
    [sudo] password for john822:
    dpkg: error processing lpr-mfc240clpr-1.0.1-1.i386.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    lpr-mfc240clpr-1.0.1-1.i386.deb
    [email protected]hn822-desktop:~$ dpkg -i --force-all
    mfc240clpr-1.0.1-1.i386.deb
    dpkg: operation requires read/write access to dpkg status area
    [email protected]:~$ dpkg -i --force-all
    mfc240ccupswrapper-1.0.1-1.i386.deb
    dpkg: operation requires read/write access to dpkg status area
    [email protected]:~$ sudo dpkg -i --force-all
    mfc240clpr-1.0.1-1.i386.deb
    dpkg: error processing mfc240clpr-1.0.1-1.i386.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    mfc240clpr-1.0.1-1.i386.deb
    [email protected]:~$ sudo dpkg -i --force-all lpr-1.0.1-1
    dpkg: error processing lpr-1.0.1-1 (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    lpr-1.0.1-1
    [email protected]:~$ sudo dpkg -i --force-all /lpr
    dpkg: error processing /lpr (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    /lpr
    [email protected]:~$
    :(:blush: :S
  • mfillpot
    mfillpot Posts: 2,177
    The instructions failed because you told the system to install the package from the / or root directory, if you are in the same directory as the packaged you only call the package name, if you are not in the directory you call the directory name prior to the package name which is what I tried to explain.

    If this does not make sense you can respond and tell me the directory that the package is in and the name of the package and I will tell you the exact syntax.
  • jhaskins75
    jhaskins75 Posts: 128
    Ok, Ok...I definitely have my neurons misfiring....I explained that I am far, far nowhere near understanding the cryptographic intelligence necessary for me to understand what I am supposed to do. In Laymen terms. When I first download the package to my installer manger and before I click the button to install, It is giving me to choices at that point! Open with gdebi installer or save it to file. Now if you where, were I am sitting what would you do? Install it to my home folder which is john822, as that method let's me view the actual file when I click onto my download folder or preceed with opening the gdebi manger and automatically let it install, which goes to my synaptic manager to be updated. From that point, i plug in my printer, turn on the power and instantly a pop up says can not detect printer driver. I openly offer you complete access to my system a desktop support method using my installed program called Teamviewer5, which all you would have to do is go to www.teamviewer.com and used the open web application and click on connect to partner with this ID 663611305 and password 8443 which you will see remote support feature displayed and you will be directly into my system and see exactly what I am trying to convey. It is active as this message reaches you and I will leave it active. You can call me, John at 202.486.5376 for verification.

Categories

Upcoming Training