Welcome to the Linux Foundation Forum!

Lab2 3a

In this lab, I get this message in my working terminal and the terminal showing the fluentd running logs

:~/labsys/lab2$ curl -X POST -d 'json={"lfs242":"hello from http"}' http://localhost:32767/mod2/http
500 Internal Server Error
Input/output error @ io_write - <STDOUT>
2022-05-12 23:15:28 +0000 [info]: adding source type="http"
2022-05-12 23:15:28 +0000 [warn]: #0 [http_input] LoadError
2022-05-12 23:15:28 +0000 [info]: adding source type="monitor_agent"
2022-05-12 23:15:28 +0000 [info]: adding source type="debug_agent"
2022-05-12 23:15:28 +0000 [info]: #0 shutting down fluentd worker worker=0
2022-05-12 23:15:28 +0000 [info]: #0 shutting down input plugin type=:forward plugin_id="forward_input"
2022-05-12 23:15:28 +0000 [info]: #0 shutting down input plugin type=:monitor_agent plugin_id="monitor_agent_input"
2022-05-12 23:15:28 +0000 [info]: #0 shutting down input plugin type=:http plugin_id="http_input"
2022-05-12 23:15:28 +0000 [info]: #0 shutting down input plugin type=:debug_agent plugin_id="debug_agent_input"
2022-05-12 23:15:28 +0000 [info]: #0 shutting down output plugin type=:forward plugin_id="forward_output"
2022-05-12 23:15:28 +0000 [info]: #0 shutting down output plugin type=:stdout plugin_id="stdout_output"
2022-05-12 23:15:33 +0000 [warn]: #0 [forward_output] event loop does NOT exit until hard timeout.
2022-05-12 23:15:38 +0000 [warn]: #0 event loop does NOT exit until hard timeout.
2022-05-12 23:15:40 +0000 [warn]: #0 killing existing thread thread=#<Thread:[email protected]_loop /var/lib/gems/2.7.0/gems/fluentd-1.14.6/lib/fluent/plugin_helper/thread.rb:70 sleep>
2022-05-12 23:15:40 +0000 [warn]: #0 thread doesn't exit correctly (killed or other reason) plugin=Fluent::Plugin::ForwardOutput title=:event_loop thread=#<Thread:[email protected]_loop /var/lib/gems/2.7.0/gems/fluentd-1.14.6/lib/fluent/plugin_helper/thread.rb:70 aborting> error=nil
2022-05-12 23:15:40 +0000 [warn]: #0 [forward_output] killing existing thread thread=#<Thread:[email protected]_loop /var/lib/gems/2.7.0/gems/fluentd-1.14.6/lib/fluent/plugin_helper/thread.rb:70 sleep>
2022-05-12 23:15:40 +0000 [warn]: #0 [forward_output] thread doesn't exit correctly (killed or other reason) plugin=Fluent::Plugin::ForwardOutput title=:event_loop thread=#<Thread:[email protected]_loop /var/lib/gems/2.7.0/gems/fluentd-1.14.6/lib/fluent/plugin_helper/thread.rb:70 aborting> error=nil
2022-05-12 23:15:40 +0000 [info]: #0 restart fluentd worker worker=0
2022-05-12 23:15:40 +0000 [info]: #0 [debug_agent_input] listening dRuby uri="druby://127.0.0.1:24230" object="Fluent::Engine" worker=0
2022-05-12 23:15:40 +0000 [info]: #0 [forward_input] listening port port=24224 bind="0.0.0.0"
2022-05-12 23:17:51 +0000 [warn]: #0 [forward_output] detached forwarding server '' host="192.168.0.11" port=24224 hard_timeout=true
2022-05-12 23:17:51 +0000 [warn]: #0 detached forwarding server '' host="192.168.0.12" port=24224 hard_timeout=true

Comments

  • Can you please post the config file you used?

  • joshl
    joshl Posts: 36
    # lab2 config
    
    # Listens on a Socket
    <source>
      @type forward
      port 31604
    </source>
    
    # Listens on REST
    <source>
      @type http
      port 32767
    </source>
    
    # in_tail plugin to tail a file. A <parse> subdirective and tag parameter are required but there are no defaults set for the in_tail plugin.
    <source>
      @type tail
      path /tmp/fluent/*.log
      tag "local.logs"
      pos_file "/tmp/fluent/lab2.tail.pos" # pos_file is recomeneded, which allow Fluentd to resume reading a file should it go down.
      <parse>
        @type none
      </parse>
    </source>
    
    <match>
      @type stdout
    </match>
    
    # END OF FILE
    
  • I reran that same command with your config and it seems to work for me.

    Can you try stopping the fluentd process then start it again?

  • joshl
    joshl Posts: 36

    thank you. i figured out what happened. i got timed out from my terminal and had to re-login. i forgot to redo this step
    ~/labsys$ export FLUENT_CONF=/home/ubuntu/labsys/lab2/lab2.conf
    after recreating the env variable, it worked.

Categories

Upcoming Training