Welcome to the Linux Foundation Forum!

Lab 7 Problem with installing sample chaincode

All the previous labs worked fine with no issues at all. I copied the exact configurations (docker-compose.yml and crypto-config.yaml from lab06 and all files from lab08) to networkFiles, ran all the commands from the instruction, received the package sacc.tar.gz, but I can't make it install properly. The error I get is:

bash-5.0# peer lifecycle chaincode install sacc.tar.gz
Error: chaincode install failed with status: 500 - failed to invoke backing implementation of 'InstallChaincode': could not build chaincode: docker build failed: docker image inspection failed: Get "http://unix.sock/images/dev-peer0.org1.example.com-sacc_1.0-5562f868f6fd43ff8873f403aa52bc6928161fec933065d0b81e2193f6038bd0-5e7a630670c7a846e2eddc91549be54dd1276bcd7ef806e18664c2c474ff5cd4/json": dial unix /host/var/run/docker.sock: connect: no such file or directory

Did anyone have a similar problem? Do you have any suggestions where to start looking for problems?

My env variables match the ones from instruction.

Comments

  • Bobbijn
    Bobbijn Posts: 133

    @wojcmarcin, Hello, lets see if we can get to the bottom of this. A suggestion would be to check the path of the sacc.tar.gz you are trying to install. Let me know if this helps. Bobbi

  • wojcmarcin
    wojcmarcin Posts: 4

    @Bobbijn Hello, the path in the container is /root/sacc.tar.gz, and I made sure that I am in that folder before running the command. I attach this file, in case that is also important.

  • wojcmarcin
    wojcmarcin Posts: 4

    I would also like to add that I checked if the file /host/var/run/docker.sock exists and it does, as a symlink

    bash-5.0# ls -la /host/var/run/ | grep docker
    srw-rw-rw-    1 root     root             0 Mar  9 07:18 com.docker.vmnetd.sock
    lrwxr-xr-x    1 root     root            79 Mar  9 07:19 docker-cli.sock -> /Users/wojcmarcin/Library/Containers/com.docker.docker/Data/docker-cli.sock
    lrwxr-xr-x    1 root     root            45 Mar  9 07:19 docker.sock -> /Users/wojcmarcin/.docker/run/docker.sock
    
  • wojcmarcin
    wojcmarcin Posts: 4

    The problem occurs in Lab 8 not 7, I can't change the title of discussion anymore.

  • matisalimba
    matisalimba Posts: 17

    Hey @wojcmarcin where you able to get around this, facing same issue

  • matisalimba
    matisalimba Posts: 17

    Oddly enough, I got to fix this problem by updating Docker desktop. I'm running the labs on an Apple M1 chip. ref: https://github.com/hyperledger-labs/minifabric/issues/314.

    My guess is that the fix will work on other unix as well.

Categories

Upcoming Training