Welcome to the Linux Foundation Forum!

LFS258 Lab 3.2 Looks incomplete

I am on lab Lab 4.1. Basic Node Maintenance now and I need to perform kubectl get node on my worker node
But I receive error message:

The connection to the server localhost:8080 was refused - did you specify the right host or port?

I've go back to lab 3.2 Grow the cluster to look if I missed something. But in this lab the last item is

8.Try to run thekubectl command on the secondary system. It should fail. You do not have the cluster or authenticationkeys in your local.kube/configfile.

And that's all. No info about how to deal wit this.

Next Lab 3.3. Finish Cluster Setup also does not have any instructions.

Can ayone help with this? I've stuck

Best Answer

  • chrispokorni
    chrispokorni Posts: 1,458
    Answer ✓

    Hi @oryzhenko,

    As noted by @alihasanahmedk in his comment, the kubectl CLI tool was not intended to be run from the worker node, hence the expectation that "it should fail", based on the quote from lab exercise 3.2.

    However, in lab exercise 4.1, I can't seem to locate the instruction to run kubectl get node from the worker node. Would you mind sharing the version of the lab material you are referencing and the step number in lab exercise 4.1 that instructs you to do so?

    Regards,
    -Chris

Answers

  • alihasanahmedk
    alihasanahmedk Posts: 32
    edited February 18

    @oryzhenko
    you cannot run kubectl agent on the worker nodes.

  • I've look through lab 4.1 again and found I was wrong. There is cp in command prompt. Sorry, I should do less learning at night

Categories

Upcoming Training