Welcome to the Linux Foundation Forum!

Lab 9.5. Enable StartTLS for Postfix, and Force Plain-Text Logins to Use StartTLS

Hi fellow learners,
I have found myself a bit stuck on this lab.
it says in the instruction that

cat /tmp/postfix.key > /etc/postfix/postfix.pem

I have tried this but i am denied even when i use sudo

Please can anyone help me.

Comments

  • k0dard
    k0dard Posts: 93

    Hello davidboadu,

    The redirection (>) opens a new shell so you either have to switch to root user account instead of using sudo or do something like this

    cat /tmp/postfix.key | sudo tee /etc/postfix/postfix.pem

  • lee42x
    lee42x Posts: 351
    edited October 2021

    Another option is the interactive option in sudo:
    $ sudo -i
    # cat /tmp/postfix.key > /etc/postfix/postfix.pem
    # exit

  • thanks i tried that and it worked

Categories

Upcoming Training