Welcome to the Linux Foundation Forum!

Multiple-choice questions do not work correctly

I was advised by to put it here:

There are multiple problems with multiple-choice questions 4.3 and 4.6 (probably other as well) in A Beginner's Guide to Linux Kernel Development (LFD103):
1. On mobile Firefox the interface behaved somewhere in between single-choice and multiple-choice: when I tap on an item it gets selected and some other items get deselected, but some remain selected. Repeat tap does not deselect an item and deselecting all but one item is not possible.
2. On desktop Firefox the interface works as for the multiple-choice question, even though the question was probably intended to be single-choice.
3. When "All of the above" item AND literally all items above it are selected the answer is considered incorrect even though it is technically correct.

Hopefully someone who can correct the wording or code behind the quiz will see this message.

Comments

  • fcioancafcioanca Posts: 803

    @qm2k Have you tried using a browser other than Firefox? Unfortunately, we can't control the platform behavior on all browsers. All we can advise is to clear your cache, and/or try a different browser. For example, questions work as expected using Chrome.

    For Q3, in such instances, only one answer is considered correct, unless "Select all answers that apply" is added to the questions to flag the existence of multiple correct answers. We have now added additional language, to specify that only one answer is correct.

  • qm2kqm2k Posts: 2

    Of all sites in the internet, I was least expecting to hear the requirement to use proprietary browser here. I don't have many Chrome installations around, but I will check the behavior in different browsers when I have this opportunity.

Sign In or Register to comment.