Welcome to the Linux Foundation Forum!

Can't install yum-plugin-verify package on RHEL 8.3?

I've tried a few times to install the yum-plugin-verify but I keep getting an error. Running "sudo yum install yum-plugin-verify" gives the error: "No match for argument: yum-plugin-verify".

Best Answer

  • coop
    coop Posts: 754
    Accepted Answer

    This is a yum command that is in CentOS/RHEL 7, but is not in CentOS/RHEL 8, as it is not in the dnf wrapper for yum as yum does not exist anymore. I believe this is noted in the course but I don't have it in front of me now.

Answers

  • ryankamp
    ryankamp Posts: 2
    edited January 21

    Thanks for the answer! It does mention that "dnf does not have an equivalent verify plugin command or option." but isn't mentioned that yum is really dnf on RHEL 8. It does mention that "dnf will underlie yum in RHEL 8" a few sections later, but that isn't very clear either.

  • coop
    coop Posts: 754

    The section on verifying packages says in a large highlighted box at the bottom:

    > dnf does not have an equivalent verify plugin command or option.

    Sometime in the not so far future, we will rewrite the sections to be about dnf rather than yum as both RHEL 8 and Fedora are dnf-based; we have just been waiting for the migration of the LFCS exam to CentOS 8

Categories

Upcoming Training