Welcome to the Linux Foundation Forum!

Lab 4 instanttiate chaincode error

When trying to initiate chain code that has been install I receive the following error:
[email protected]:/opt/gopath/src/github.com/hyperledger/fabric/peer# peer chaincode instantiate -n ccForAll -v 1.0 -o orderer.example.com:7050 -C allarewelcome -c '{"Args":["Mach","50"]}' --policy "AND('Org1.peer', OR ('Org1.member'))"
2020-07-12 12:20:10.574 UTC [main] InitCmd -> WARN 001 CORE_LOGGING_LEVEL is no longer supported, please use the FABRIC_LOGGING_SPEC environment variable
2020-07-12 12:20:10.594 UTC [main] SetOrdererEnv -> WARN 002 CORE_LOGGING_LEVEL is no longer supported, please use the FABRIC_LOGGING_SPEC environment variable
Error: error getting endorser client for instantiate: endorser client failed to connect to peer0.org1.example.com:7051: failed to create new connection: context deadline exceeded
[email protected]:/opt/gopath/src/github.com/hyperledger/fabric/peer#

Has anyone found this issue?

Comments

  • Niklaskkkk
    Niklaskkkk Posts: 113

    @Paolo Marin said:
    When trying to initiate chain code that has been install I receive the following error:
    [email protected]:/opt/gopath/src/github.com/hyperledger/fabric/peer# peer chaincode instantiate -n ccForAll -v 1.0 -o orderer.example.com:7050 -C allarewelcome -c '{"Args":["Mach","50"]}' --policy "AND('Org1.peer', OR ('Org1.member'))"
    2020-07-12 12:20:10.574 UTC [main] InitCmd -> WARN 001 CORE_LOGGING_LEVEL is no longer supported, please use the FABRIC_LOGGING_SPEC environment variable
    2020-07-12 12:20:10.594 UTC [main] SetOrdererEnv -> WARN 002 CORE_LOGGING_LEVEL is no longer supported, please use the FABRIC_LOGGING_SPEC environment variable
    Error: error getting endorser client for instantiate: endorser client failed to connect to peer0.org1.example.com:7051: failed to create new connection: context deadline exceeded
    [email protected]:/opt/gopath/src/github.com/hyperledger/fabric/peer#

    Has anyone found this issue?

    Hi @Paolo Marin ,

    Would suggest to try and tear down your network and try it again. I just did Lab 4 withouth any issues. Difficult to say, but might be related to versions of your images.

    If you want to continue from current state instead, please try the following:

    Install the new chaincode version on the required endorser
    Upgrade the chaincode by invoking the "peer chaincode upgrade" command
    

    This is from the official Hyperledger Fabric documentation: "Prior to upgrade, the new version of the chaincode must be installed on the required endorsers. Upgrade is a transaction similar to the instantiate transaction, which binds the new version of the chaincode to the channel. Other channels bound to the old version of the chaincode still run with the old version. In other words, the upgrade transaction only affects one channel at a time, the channel to which the transaction is submitted."

    Link: https://hyperledger-fabric.readthedocs.io/en/release-1.4/chaincode4noah.html#upgrade

  • Szymon
    Szymon Posts: 7

    Also have issues with super Lab4.... when trying to instantiate code error I got is:

    Error: could not assemble transaction, err proposal response was not successful, error code 500, msg error starting container: error starting container: API error (404): network startFiles_basic not found
    

    Seriously, you couldn't come up with some folder structure which exists?
    Also, running scripts from Desktop folder is just completely stupid.

    So, should I read code now to find out where are some paths hardcoded?
    Total disaster. Course is really waste of time. Whoever wrote it has no clue how courseware should be done and how to prepare labs.

    How can I fix error with 404 then?
    Maybe this time you will be able to respond, rather than patronizing me how I should write posts.
    So far it is waste of time... every time I try to proceed with this courseware I got pushed away by low quality level provided.
    It is total disaster.

  • fcioanca
    fcioanca Posts: 998

    Hi @Szymon, we understand your frustration and apologize for the problems encountered. As mentioned previously, we are aware the course needs updates and the course authors are working on them, without an ETA. In the meantime, there have been good suggestions in the forum that you could try to use to get through the labs.

    We do have to reiterate that we expect all students to be polite and respectful. Feedback can be provided in a constructive way; disrespectful language will not lead anywhere - this is not about patronizing you, it's about common sense.

  • Szymon
    Szymon Posts: 7

    Well, then some appendix should be published where all trash made in labs would be cleandup.
    From one error to another... next one on the list:

    API error (404): network _BASIC not found
    

    Seriously??? Anyone did test those file at least once? I don't think so.
    You should learn from crypto projects how to deliver efficient manner.
    Most of them do not charge anything and deliver quality documentation.
    You charging $$$ and can't evet tell people when you fix your low quality materials (that is soft description, so another language specialist won't be crying like little baby)?
    Seriously???
    Is this for real?

  • Szymon
    Szymon Posts: 7

    Btw.. keep in mind that people reporting all issues over a year... and you still didn't manage to fix anything or publish some document with all errors listed?
    Pathetic!

  • mstepien
    mstepien Posts: 216

    Hi Szymon,

    As @fcioanca said, we apologize for any inconvenience and we are working to improve and update this course. Please reach out to our Customer Support if you need further assistance: [email protected]

    Thank you,
    Magda

  • Szymon
    Szymon Posts: 7

    Now I can't even search your "super" forum for resolutions as I get this:

    Something has gone wrong.
    We've run into a problem and are unable to handle this request right now.
    Please check back in a little while.
    

    Absolute disaster!

  • fcioanca
    fcioanca Posts: 998

    @Szymon To reiterate again, please be respectful in your posts, as this attitude is not appropriate.

  • Niklaskkkk
    Niklaskkkk Posts: 113

    @Szymon said:
    Also have issues with super Lab4.... when trying to instantiate code error I got is:

    Error: could not assemble transaction, err proposal response was not successful, error code 500, msg error starting container: error starting container: API error (404): network startFiles_basic not found
    

    Seriously, you couldn't come up with some folder structure which exists?
    Also, running scripts from Desktop folder is just completely stupid.

    So, should I read code now to find out where are some paths hardcoded?
    Total disaster. Course is really waste of time. Whoever wrote it has no clue how courseware should be done and how to prepare labs.

    How can I fix error with 404 then?
    Maybe this time you will be able to respond, rather than patronizing me how I should write posts.
    So far it is waste of time... every time I try to proceed with this courseware I got pushed away by low quality level provided.
    It is total disaster.

    Hi @Szymon ,

    I have previously experienced the same error. It might be due to spelling mismatch from the setup script, so try to change the parameter in the docker-compose file (to a small f):

    CORE_VM_DOCKER_HOSTCONFIG_NETWORKMODE=starfiles_basic

    Try to restart network after this, to see if it works.

  • Szymon
    Szymon Posts: 7

    @Niklaskkkk I did fix this one already.. now stuck with this

    Error: got unexpected status: NOT_FOUND -- channel does not exist
    
  • Szymon
    Szymon Posts: 7

    @fcioanca if you woud provide valuable answers not BS about language and some kiddo-like comments then would be no problem.
    If you didn't notice.. during whole conversation none of you provided any valuable answers.. instead of just "we trying to fix it"... over the year... so, don't you think your responses are completely useless?
    Writing for the sake of writing? OMG! Instead of placing this type of comments go and fix your mess in training materials. Make yourself useful.

  • coop
    coop Posts: 779
    edited August 2020

    Szymon:

    You have made 7 posts in less than two hours on a forum which has never purported to be a real-time technical support medium. You were told the course needs some work and is in the process of updating and yet you continue to elevate your level of rudeness towards several people who are trying to be honest and patient with you. Maybe it makes you feel good to do so, but it is not a method designed to achieve results. I would suggest you calm down and please try to be polite and treat people with respect as they have done with you.

    Keeping cutting edge technology learning material up to date is not easy as upstream changes often and experts are in short supply. I seriously doubt you will find many competitive alternatives to LFS272, so please keep your powder a little drier and it will be appreciated.

  • terany
    terany Posts: 5

    @Szymon said:
    @Niklaskkkk I did fix this one already.. now stuck with this

    Error: got unexpected status: NOT_FOUND -- channel does not exist
    

    Run, "docker exec -it peer0.org1.example.com peer channel list" to list joined channels and use that name in instantiate command.

Categories

Upcoming Training