Welcome to the Linux Foundation Forum!

error : attempt to read or write outside of disk 'hd0'. Entering rescue mode ...

Hello everybody,
I am following the guidelines to prepare a CentOS7 virtual machine. I have downloaded the CentOS7.tar.xz file, decompressed it, and indicated to Virtualbox where to find the .vmdk file. However, when I start the machine, I get:

error : attempt to read or write outside of disk 'hd0'.
Entering rescue mode ...
grub rescue >

I have tried doing this on the grub rescue command line:

grub rescue > ls
(hd0) (hd0, msdos2) (hd, msdos1)
grub rescue > ls (hd0,msdos1)/ # This is where Linux is running
grub rescue > set boot=(hd0,msdos1)
grub rescue > set prefix=(hd0,msdos1)/boot/grub
grub rescue > insmod normal
grub rescue > normal

However, when I type in : insmod normal , the same error comes out:

error : attempt to read or write outside of disk 'hd0'.

Also, I would like to specify that I am running Virtualbox on Mac OS Sierra.

Thank you for your time.


  • Hi @hbellal ,

    Just to be sure, did you get this vmware image from the Linux Foundation training website? If so, I can get the image and test it.


  • coopcoop Posts: 726

    I have just run the Linux FOundation VM on latest virtual box (6.0.12) and it runs without problem. Can you please make sure your hard drive is set to "SCSI" and not "SATA" as that is a common problem, and that in itself is not encoded in the vmdk file, as it is a local set up option.

  • coopcoop Posts: 726

    I am on a Linux Host, but that should not make a difference, as compared to a Mac or a Windows PC

  • Hello luisviveropena,
    Yes, I have taken the vmware image from the Linux foundation traning website. More specifically from the link at the end of this page :

    Thank you.

  • Hello coop,
    Indeed the hardrive type was set to SATA. However, now, I have :
    1. Added a new storage controller of type SCSI.
    2. Added a new hardrive under it and associated it with the CentOS7.vmdk file.
    3. Deleted the SATA storage controller and all of its hardrives.

    But I still have the same problem. Here is a screenshot of my configuration related to storage, it's in French, but I'm sure you'll be able to decypher it :

    Thank you.

  • coopcoop Posts: 726

    no idea. Looks exactly like what I have in English. What is likely to take you less time is to download the CentOS7 iso, and do a fresh install in VirtualBox (that will take no more than 15 minutes) and it will do an authomatic install which will ask you not even any questions. Then once it is done, just run the ready-for.sh script (which you can get from https://training.linuxfoundation.org/cm/prep (and is mentioned in the course as well) and just do a one liner:

    ./ready-for.sh --install LFS201

    and voila, in a few minutes you should have a clean virtual machine with all the software you need.

    That's what I would do. :)

    Bonne chance!

  • Hello everybody,
    I have decompressed the downloaded .xz file one more time and linked the resulting vmdk to my machine, and this time it works, after changing storage controller type to SCSI. I think that during the first decompression, something might have gone wrong. Anyways, thank you all for your concern, and I hope to come back with a real problem next time.

  • Hi @hbellal ,

    It's good to know that it's working now! Did you download the file again, or just decompressed the file again?


  • Just decompressed it.

  • Well, that's weird, at least you used a different command the second time.


  • I got stuck in the same problem when I downloaded the CentOS image and decompressed it in Ubuntu 20.10 and then I tried to use the decompressed file in Win10. When I decompressed it with 7zip in Win10, the image charged smoothly

  • coopcoop Posts: 726

    i have seen this before. the built in windows decompression program is out of spec but 7zip should work. i believe the README file may even say so

Sign In or Register to comment.