Welcome to the new Linux Foundation Forum!

LAB 2 Command error

I am following the document instruction to create a new peer for the network, but after issuing the command

docker-compose -f docker-compose.yml up \ -d peer0.org1.example.com peer1.org1.example.com cli

WARNING: The COMPOSE_PROJECT_NAME variable is not set. Defaulting to a blank string.
ERROR: No such service: -d

What is the correct command i suppose to issue ? is the \ sign prob ?

thanks

Comments

  • sksongsksong Posts: 12

    If i remove the \

    docker-compose -f docker-compose.yml up -d peer0.org1.example.com peer1.org1.example.com cli

    I can see
    WARNING: The COMPOSE_PROJECT_NAME variable is not set. Defaulting to a blank string.
    Starting cli ... done
    Starting orderer.example.com ... done
    Starting peer1.org1.example.com ... done
    Starting peer0.org1.example.com ... done

    When i check with
    docker ps --filter name=peer
    CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
    c0599fc788c0 hyperledger/fabric-peer "peer node start" 7 hours ago Up 4 minutes 0.0.0.0:7051->7051/tcp, 0.0.0.0:7053->7053/tcp peer0.org1.example.com

    it only show me one peer, mean peer1 is not up.

    Any one can assist on this

    thanks

  • sksongsksong Posts: 12

    Solve all the issues. PDF file viewier issue cause the command line copy and paste wrongly.
    I view the pdf with pdf viewer and edge browser ,both cause the cmd line some alignment issue.
    Open with chrome browser will work perfectly for now.

  • indirajithindirajith Posts: 11

    Even for me the Peer1 does not start up. The docker logs for that container shows as follows:

    [main] InitCmd -> ERRO 001 Cannot run peer because error when setting up MSP of type bccsp from directory /etc/hyperledger/msp/peer/: the supplied identity is not valid: x509: certificate signed by unknown authority.

    The structure of MSP is still not that clear. if something goes wrong, one should be able to troubleshoot it. Would be of great help if we have more material on MSP structure and functionalities.

    Please anyone having a clear knowledge about the aforementioned problem, help me.

  • akoitaakoita Posts: 7

    Hi @indirajith, I hope your issue is already solved, if not here is a suggestion.

    The error can be due to stale data in docker cache, I will suggest to clean docker state an retry again. You can clean the containers, the volumes and the networks as follows:

    docker rm -f $(docker -aq)
    docker volume prune -f
    docker network prune -f
    
  • indirajithindirajith Posts: 11

    Thanks Akoita, I just overcame the above issue. I found the CA's cert for both peers are not the same so deleted them manually and generated cryptofiles again and it works now.

Sign In or Register to comment.