Welcome to the new Linux Foundation Forum!

Error while running Kubeadm join on minion node

Both Master and Worker is showing version as 1.12

Master

kubeadm version

kubeadm version: &version.Info{Major:"1", Minor:"12", GitVersion:"v1.12.1"

Minion

kubeadm version

kubeadm version: &version.Info{Major:"1", Minor:"12", GitVersion:"v1.12.1"

and same version is shown for kubectl and kubelet.

However docker images version shown as 1.13 on master -

REPOSITORY TAG IMAGE ID CREATED SIZE
k8s.gcr.io/kube-proxy v1.13.1 fdb321fd30a0 2 weeks ago 80.2MB
k8s.gcr.io/kube-scheduler v1.13.1 ab81d7360408 2 weeks ago 79.6MB
k8s.gcr.io/kube-apiserver v1.13.1 40a63db91ef8 2 weeks ago 181MB
k8s.gcr.io/kube-controller-manager v1.13.1 26e6f1db2a52 2 weeks ago 146MB

I am getting below error while trying to run the kubeadm join command -

[kubelet] Downloading configuration for the kubelet from the "kubelet-config-1.12" ConfigMap in the kube-system namespace
configmaps "kubelet-config-1.12" is forbidden: User "system:bootstrap:f6fsp5" cannot get resource "configmaps" in API group "" in the namespace "kube-system"

I tried running command "sudo kubeadm init --kubernetes-version 1.12.1 --pod-network-cidr 192.168.0.0/16" on Master but it fails with an below error -

init] using Kubernetes version: v1.12.1
[preflight] running pre-flight checks
[preflight] Some fatal errors occurred:
[ERROR Port-6443]: Port 6443 is in use
[ERROR Port-10251]: Port 10251 is in use
[ERROR Port-10252]: Port 10252 is in use
[ERROR FileAvailable--etc-kubernetes-manifests-kube-apiserver.yaml]: /etc/kubernetes/manifests/kube-apiserver.yaml already exists
[ERROR FileAvailable--etc-kubernetes-manifests-kube-controller-manager.yaml]: /etc/kubernetes/manifests/kube-controller-manager.yaml already exists
[ERROR FileAvailable--etc-kubernetes-manifests-kube-scheduler.yaml]: /etc/kubernetes/manifests/kube-scheduler.yaml already exists
[ERROR FileAvailable--etc-kubernetes-manifests-etcd.yaml]: /etc/kubernetes/manifests/etcd.yaml already exists
[ERROR Port-10250]: Port 10250 is in use
[ERROR Port-2379]: Port 2379 is in use
[ERROR DirAvailable--var-lib-etcd]: /var/lib/etcd is not empty
[preflight] If you know what you are doing, you can make a check non-fatal with --ignore-preflight-errors=...

Let me know how to fix this and on which node to run the commands.

Comments

  • chrispokornichrispokorni Posts: 266

    Hi @pranavrathore ,
    A fix has been posted in an earlier discussion on the same topic.
    Please use the following command to fix these errors:

    sudo kubeadm reset on both nodes, then run this command again:

    sudo kubeadm init --kubernetes-version 1.12.1 --pod-network-cidr 192.168.0.0/16

    You can search thru earlier discussions to see if your specific issue has already been resolved.
    Regards,
    -Chris

Sign In or Register to comment.