Welcome to the Linux Foundation Forum!

Lab 2.1 multi container pod not working (Fluentd fails)

The logs from the fluentd container indicates the following reason for the container failure.

I am running the lab on two Unbuntu vms, not on google cloud. However, from the logs, it cannot determine the platform. Then it cannot load the defaut credentials for Google Cloud. I am not using Google cloud.

Anyone have ideas how to resolve? It appears that the lab is making some incorrect assumptions about my environment and is getting confused.


adding match pattern="kubernetes.**" type="google_cloud"
2018-11-09 15:09:01 +0000 [warn]: 'block' action stops input process until the buffer full is resolved. Check your pipeline this action is fit or not
2018-11-09 15:09:01 +0000 [info]: Unable to determine platform
2018-11-09 15:09:01 +0000 [error]: unexpected error error="Could not load the default credentials. Browse to\nhttps://developers.google.com/accounts/docs/application-default-credentials\nfor more information\n"
2018-11-09 15:09:01 +0000 [error]: /opt/td-agent/embedded/lib/ruby/gems/2.1.0/gems/googleauth-0.5.1/lib/googleauth.rb:119:in `get_application_default'

Comments

Sign In or Register to comment.