Welcome to the new Linux Foundation Forum!

Vagrant error

Getting the following error in the first lab:

Mac-mini:HyperLedger antonioslaaf$ vagrant up
There are errors in the configuration of this machine. Please fix
the following errors and try again:

AWS Provider:

  • An AMI must be configured via "ami" (region: #{region})

Comments

  • JonathanLeviJonathanLevi Posts: 25
    edited September 21

    Hi Antonio, Jonathan Levi from HACERA here.

    Sorry, I have just seen this.

    Is it possible that you are trying to run this from an Amazon cloud? The "AMI" (Amazon Machine Image) in the error message, suggests that.

    While we don't officially support this (the official support is for Linux, MS-Window or Mac), out of interest, can you try either:

    • delete vagrant-aws module
      or

    • run Vagrant with --provider=virtualbox

    Please let me/us know?
    Thanks.

Sign In or Register to comment.