Welcome to the new Linux Foundation Forum!

Lab 35.1 chmod command syntax not working as intended in Centos7

In lab 35.1 it is suggested to try

$ chmod u=+w,g=-w,o=+rw afile

to explore adding permissions to existing ones but the u=+w in simply recognised as u=w. The [ugoa]=-[rwx] syntax removes all permissions, not just the one requested, eg g=-w removes all permission for g leaving them as blank ---

Not sure about in other distributions, only tried in Centos7.

chmod [ugoa]+-[rwoa] works correctly though.



  • Hi,

    I'm going to try the lab on CenOS 7 and I'll let you know what I found.



  • nel242nel242 Posts: 1


    works for me on Centos 7.


  • Hi,

    I tried the three exercices and all of them worked for me on CentOS 7. Can you provide a screenshot with the non working ones, please?



  • JdcS9JdcS9 Posts: 2

    Sure, this is what I get when I try u=+x as in the lab instead of u+x :

  • Hi,

    Right, if I'm not wrong, we should expect to add 'x' and not to replace anything with 'x' when we do '+x'. I'm going to check on this and I'll let you know.



  • MM69MM69 Posts: 2

    Same here; looks to me like we should just leave out the '=' when using +/-, at least in CentOS 7:

    [[email protected] ~]$ ls -l afile
    -r---w---x. 1 marc marc 0 Aug 29 13:26 afile
    [[email protected] ~]$ chmod u=+w,g=-w,o=+rw afile
    [[email protected] ~]$ ls -l afile
    --w----rw-. 1 marc marc 0 Aug 29 13:26 afile
    [[email protected] ~]$ chmod u=r,g=w,o=x afile
    [[email protected] ~]$ chmod u+w,g-w,o+rw afile
    [[email protected] ~]$ ls -l afile
    -rw----rwx. 1 marc marc 0 Aug 29 13:26 afile
  • coopcoop Posts: 277

    There is no problem here. The exercise is to try variations and see what is happening, which is exactly what you are doing. We never say chmod u=+x or u=x or u+x are the same or different. None of these are invalid syntaxes. (u=x and u=+x are indeed the same and different from u+x).

  • I think the exercise would have been served better if some explanation went with it, at least to why one would want to it this way.

    From the manual.

    The operator + causes the selected file mode bits to be added to the existing file mode bits of each file; - causes them to be removed; and = causes them to be added and causes unmentioned bits to be removed

    Effectively, in your example, this mean the = will clear the bits and the "+w" is added.

    The thing is not mentioned in the manual is that the does not apply to only the "original" bits from the file, but the bits changed to that point in executing the command. Basically the program go through every change on the command an apply.

    Therefore, you could go crazy and write something like o=+w-w=r+rw=x and you will end up with o=x. The program simply stepped through each command on "o": clear all -> set w -> remove w -> set r and clear others -> set rw -> set x and clear others -> done.

    chmod -v o=+w-w=r+rw=x me
    mode of 'me' changed from 0664 (rw-rw-r--) to 0661 (rw-rw---x)

    sudo chmod -v o= me
    mode of 'me' changed from 0661 (rw-rw---x) to 0660 (rw-rw----)

  • coopcoop Posts: 277

    No change. The excercise simply says play with things and evaluate. That is what you have done thoroughly.

    As a personal aside, I never ever ever use any of this. It is exactly because of these confusions i always use the octal syntax, like chmod 644 file, or a lot of simple chmod +x somefile.

  • on a personal note, never any confusion if you stick to one operator and much clearer than numbers ;).

  • I prefer to use the letters, there is no confusion if you use them :)

Sign In or Register to comment.