Welcome to the new Linux Foundation Forum!

Could not start the X Server

jojocompasjojocompas Posts: 26

After a system crash, when I try to boot, I often have this message on a terminal screen

Could not start the X Server (your graphical environment due to some internal error. Please contact your system administrator or check your syslog to diagnose, in the meantime this display will be disabled. Please restart GDM when the problem is corrected.

Ubuntu 9.04 Localhost.localdomain tty1

and then I have the followin prompt

localhost.localdomain login:

!, what is the best approach to resolve booting?

also, what folder would I find the syslog?

How do I restart GDM, I'm not quite sure what it is?

I'm using Ubuntu 9.04

Comments

  • disidisi Posts: 11
    I do not know about Ubuntu, but for xorg-server it would be:
    /var/log/Xorg.0.log
    
    You probably have the file without the "0"

    gdm is "gnome desktop manager" this is a grafical login.

    I would logon to the system on console prompt (just username/password where the login: is)

    Then run "startx" and you will get more information.
  • LegacyUserLegacyUser Posts: 0
    Usually this would mean the X server is not configured properly. If you log in from the command prompt you can try reconfiguring it with
    sudo dpkg-reconfigure -phigh xserver-xorg
    

    The conf file is located at /etc/X11/xorg.conf

    To restart gdm, do
    sudo /etc/init.d/gdm restart
    

    Also, everything that disi mentioned.
  • jojocompasjojocompas Posts: 26
    Thank you all for your help, I will surely put it to test next time
  • I had troubles with x-server when I updated Ubuntu on my wife's eee-pc.

    Though I did spend some time trying to track down the problem, in my opinion it takes so little time to reinstall, that it's a better option. Now I always put her files onto a USB/SD card, and that means the data is separate from the OS. If there are x-server troubles, I spend 15-20 minutes trying to fix them, but if that doesn't work, I just reinstall. Maybe I'm lazy...
  • Ubuntu has a recovery mode. If you hit Esc right before it starts to load the kernel, you can select the second option in the grub menu which is recovery mode.

    In the menu that comes up, one of the options is "xfix - Try to auto repair graphic problems". Might work for you.
  • I had the same problem
    When it updates my Ubuntu, the X trumped me, and after trying several arrangements, the best solution was a new installation

    even not which was the program that produced the failure to me, because I did not like Xorg's update
Sign In or Register to comment.