Welcome to the new Linux Foundation Forum!

how to setup usb modem on ubuntu

ernesernes Posts: 1
edited August 2012 in Networking

I've spent the past 2 days and 1½ hour from the third day trying to figure out how to configure my USB modem to start surfing on the net. And now i give up. Obviously i dont know what i'm doing so i need some help. I'm gettin an error when trying to connect with wvdial. Here is the error from the terminal:

--> Initializing modem.

--> Sending: AT + CGDCONT=1, "IP", "bredband.tre.se"

AT + CGDCONT=1, "IP", "bredband.tre.se"

OK

--> Modem initialized.

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: AT + CGDCONT=1, "IP", "bredband.tre.se"

AT + CGDCONT=1, "IP", "bredband.tre.se"

OK

--> Modem initialized.

--> Sending: ATDT*99#

--> Waiting for carrier. ATDT*99# ~[7f]}#@!}!}!} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&URy,kT~

CONNECT

--> Carrier detected. Waiting for prompt.

~[7f]}#@!}!}"} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&URy,'9~

--> PPP negotiation detected.

--> Starting pppd at Fri Aug 17 19:20:17 2012

--> Pid of pppd: 10401

--> Using interface ppp0

--> pppd: ��B

--> pppd: ��B

--> pppd: ��B

--> pppd: ��B

--> pppd: ��B

--> pppd: ��B

--> pppd: ��B

--> Disconnecting at Fri Aug 17 19:20:18 2012

--> The PPP daemon has died: A modem hung up the phone (exit code = 16) --> man pppd explains pppd error codes in more detail.

--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.

--> Auto Reconnect will be attempted in 40 seconds

And my wvdial.conf looks like this:

[Dialer Defaults]

Init1 = AT + CGDCONT=1, "IP", "bredband.tre.se"

Modem Type = USB Modem

Phone = *99#

ISDN = 0

Username = *

Password = *

Modem = /dev/ttyACM0

Baud = 460800

Pin = 7702

This is the lsusb output: Code:

Bus 001 Device 007: ID 12d1:1505 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

Bus 001 Device 004: ID 0bdb:1902 Ericsson Business Mobile Networks BV F3507g v2 Mobile Broadband Module

I've changed the wvdial.config several times with no success and if i change Init1 to: Code:

Init1 = ATZ

Init2 = AT + CGDCONT=1, "IP", "bredband.tre.se"

i get an error saying ATZ Error Bad init string. The usb dongle is a Huawei E372 Mobile Broadband modem. It has a sim-card in it and it requires a pin number of 4 digits to be able to connect to the internet. I tested it on Ubuntu 12.0.4 and it works fine but i'm having a really hard time trying to set it up on Backtrack 5 R3. Here is a picture of the modem click hereAny help would be much appreciated.I really need some help here. Thanks in advance.

Comments

  • Most probably ur wvdial is wrong ! It might be like this:
    [Dialer Defaults]
    Modem Type = Analog Modem
    Phone = *99#
    ISDN = 0
    Baud = 460800
    Username = " " (ur user name, if don't know, contact ur vendor)
    Password = " " (ur password)
    Modem = /dev/ttyUSB0
    Init1 = ATZ
    Init2 = at+cgdcont=1,"ip","ericssonnet"

    after giving the permission as: sudo chmod 777 /etc/wvdial.conf
    Now u have to create new file in /etc/udev/rules.d and rename it as 15-huawei-e1550.rules and type contents like....
    SUBSYSTEM=="usb",
    SYSFS{idProduct}=="", (here u put ur lsbusb output)
    SYSFS{idVendor}=="12d1",

    Connect ur usb modem & wait till icon appears on desktop. (restart optional)......
    open terminal and type wvdial
    if the connection is not established properly, then u have to dnld the file called, usb-modeswitch_1.0.2-1_i386.deb from net and after install/conf u may browse.
  • Hey Guys i think that for setting up the USB modem you should download the USB modem's setup or driver into your system CD room generate. The disc's set up expert will load immediately.Select the install USB driver from the available record.Follow the driver set up wizard's on-screen rules. Doing so sets up the USB modem's driver onto your computer, setting up your elements for actual connection.Thanks!!
  • prince007prince007 Posts: 3
    edited April 2016
    I USE UBUNTU AS WELL BUT NEVER HAD ISSUES WITH USB MODEM. WHAT I DID WAS TO LOCATED NETWORK ICON AND CONFIGURE USING THE DEFAULT NETWORK SETTINGS. YOU MAY WISH TO TRY rechill_colins ADVICE IF MINE DIDNT WORK.
  • I've spent the past 2 days and 1½ hour from the third day trying to figure out how to configure my USB modem to start surfing on the net. And now i give up. Obviously i dont know what i'm doing so i need some help. I'm gettin an error when trying to connect with wvdial. Here is the error from the terminal:

  • malichiyatsiamalichiyatsia Posts: 8
    edited March 31

    @malichiyatsia said:
    I've spent the past 2 ")d ays and 1½ hour from the third day trying to figure out how to configure my USB modem to start surfing on the net. And now i give up. Obviously i dont know what i'm doing so i need some help. I'm gettin an error when trying to connect with wvdial. Here is the error from the terminal:
    https://downloader.vip/malwarebytes/ https://downloader.vip/rufus/ FileZilla

Sign In or Register to comment.