Welcome to the new Linux Foundation Forum!

Missing package compiling...

I'm trying to build DIGITS from the src package I downloaded. But there's a problem...

[email protected]:~/apps/DIGITS/DIGITS-master$ ./digits-server

Traceback (most recent call last):

File "/usr/local/bin/gunicorn", line 5, in

from pkg_resources import load_entry_point

File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3130, in

File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3116, in _call_aside

File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3143, in _initialize_master_working_set

File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 642, in _build_master

File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 943, in require

File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 830, in resolve

pkg_resources.DistributionNotFound: The 'gunicorn==17.5' distribution was not found and is required by the application

So gunicorn=17.5 isn't found? What's the correct procedure here...

Comments

  • I'm trying to build DIGITS from the src package I downloaded. But there's a problem...


    [email protected]:~/apps/DIGITS/DIGITS-master$ ./digits-server
    Traceback (most recent call last):
    File "/usr/local/bin/gunicorn", line 5, in <module>
    from pkg_resources import load_entry_point
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3130, in <module>
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3116, in _call_aside
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3143, in _initialize_master_working_set
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 642, in _build_master
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 943, in require
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 830, in resolve
    pkg_resources.DistributionNotFound: The 'gunicorn==17.5' distribution was not found and is required by the application


    So gunicorn=17.5 isn't found? What's the correct procedure here...

    This may look like a dependency issued. gunicorn is a binary package not on your system. Before you attempted to compile, did you read the documentation or the README first. Most of these source programs do have README files or something that teaches you how to compile.

    Also, I would research gunicon through a browser to a full understanding of it. For instance, http://gunicorn.org/
Sign In or Register to comment.