Welcome to the new Linux Foundation Forum!

yumError

rpmdb: Program version 4.8 doesn't match environment version 5.1

error: db3 error(-30971) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch

error: cannot open Packages index using db3 - (-30971)

error: cannot open Packages database in /root/.rpmdb

Traceback (most recent call last):

File "/usr/bin/yum", line 29, in

yummain.user_main(sys.argv[1:], exit_code=True)

File "/usr/share/yum-cli/yummain.py", line 315, in user_main

errcode = main(args)

File "/usr/share/yum-cli/yummain.py", line 159, in main

base.getOptionsConfig(args)

File "/usr/share/yum-cli/cli.py", line 189, in getOptionsConfig

self.conf

File "/usr/lib/pymodules/python2.6/yum/__init__.py", line 723, in

conf = property(fget=lambda self: self._getConfig(),

File "/usr/lib/pymodules/python2.6/yum/__init__.py", line 249, in _getConfig

startupconf = config.readStartupConfig(fn, root)

File "/usr/lib/pymodules/python2.6/yum/config.py", line 807, in readStartupConfig

startupconf.releasever = _getsysver(startupconf.installroot, startupconf.distroverpkg)

File "/usr/lib/pymodules/python2.6/yum/config.py", line 914, in _getsysver

idx = ts.dbMatch('provides', distroverpkg)

_rpm.error: rpmdb open failed

How should I do?!!!!!!!!!!!!!!!

Comments

  • marcmarc Posts: 647
    Distro? is it updated? do you have all the necessary python packages installed?

    We need much more information that just an error

    Regards
  • designerdesigner Posts: 11
    What are you want? Tell me! I'll give you. But this error has shown a message "rpmdb: Program version 4.8 doesn't match environment version 5.1", do you seen?!!!!!!!!!!!!!!!Can you fix it?
  • Goineasy9Goineasy9 Posts: 1,116
    Database environment version mismatch. This is telling you that yum is not going to work with Debian. Apt-get or aptitude is for installing in a Debian environment.

    This might be helpful:
    https://en.wikipedia.org/wiki/Linux_package_formats
  • mfillpotmfillpot Posts: 2,180
    We need to know what Linux based distro you are using and if you have applied all of the updates to the OS and applications?

    Without knowing the distro that you are using we will not know of the chosen package is for your system. Additionally can you tell us the application that you are trying to install and possibly link to the app website so we have a point of reference?
  • designerdesigner Posts: 11
    Linux version 2.6.32-5-amd64 (Debian 2.6.32-45) ([email protected]) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Sun May 6 04:00:17 UTC 2012





    new debian package, version 2.0.
    size 633956 bytes: control archive= 3464 bytes.
    185 bytes, 7 lines conffiles
    984 bytes, 25 lines control
    5414 bytes, 79 lines md5sums
    507 bytes, 17 lines * postinst #!/bin/sh
    178 bytes, 7 lines * postrm #!/bin/sh
    462 bytes, 16 lines * prerm #!/bin/sh
    Package: yum
    Version: 3.2.25-1
    Architecture: all
    Maintainer: Thomas Goirand <[email protected]d.fr>
    Installed-Size: 2120
    Depends: python, python-support (>= 0.90.0), python (>= 2.5) | python-celementtree, python-libxml2, python-urlgrabber, rpm (>= 4.4.1), python-rpm, python-sqlitecachec, python-sqlite
    Section: admin
    Priority: extra
    Homepage: http://yum.baseurl.org/
    Description: Advanced front-end for rpm
    Yum (Yellow dog Updater, Modified) is an automatic updater and package
    installer/remover for rpm systems. It automatically computes dependencies
    and figures out what things should occur to install packages. It makes it
    easier to maintain groups of machines without having to manually update
    each one using rpm.
    .
    Features include:
    .
    * Multiple Repositories
    * Simple config file
    * Correct dependency calculation
    * Fast operation
    * rpm-consistent behavior
    * comps.xml group support, including multiple repository groups
    * Simple interface


    I can give everything you want, if you can resolve this problem. thanks.
  • mfillpotmfillpot Posts: 2,180
    You already answered the question as to why that package won't install, "Yum (Yellow dog Updater, Modified) is an automatic updater and package installer/remover for rpm systems" your system is debian based, not rpm based. As goingeasy stated, you use the apt-get and aptitute applications to install application on debian based systems. apt-get is functionally the same as yum and it is already installed on your computer.

    http://wiki.debian.org/Apt
  • designerdesigner Posts: 11
    But when i use the dpkg -i package install package, i often met the dependency problem. I have to one by one download the package i need. You this is so boring?!!!!!!!!!!Is it have a easy way to install package?!!!!!!!!!!
  • designerdesigner Posts: 11
    Other, if the debian system can't install yum package, why debian website have a yum package?!!!!!!!!!!
  • Goineasy9Goineasy9 Posts: 1,116
    That's actually a very good question. Why does Debian have a yum installer? Well, because some developer believes he can make it work. Unfortunately, he/she hasn't perfected it. Just because a package is there, doesn't mean it doesn't have a lot of bugs, and, yum commands in Debian, as well as deb/dpkg/apt commands in Fedora/OpenSuse/Mandriva have a lot of bugs. And, even though alien has been around for a long time, I've personally never heard a good review of it. If you mention it on any Debian based forum, the answer is "Don't use it". If you mention it on a Fedora forum, the answer is, "Don't use it". So, if you're advised not to use it on forums that use either .deb or .rpm packages, the two package types that its suppose to work with, go with the advise, don't use it. Use what works. Use .deb with .deb based distros, and, use .rpm on .rpm based distros.
  • oldgioldgi Posts: 4
    I was just doing an install to USB flash drive and the partition format for the boot partition in ext4 format never finished and I go this error. I used gpart to format the partition and re-started the install and it went OK....

    Thanks for all the responses..... you guys are great....

    Finally a Ubuntu distro that I think I can live with..... Ubuntu 12.04 LTS shines bright for the future...

    Upgrades takes far to long when installing on a USB Flash Drive.....
  • designerdesigner Posts: 11
    But when i use the dpkg -i package install package, i often met the dependency problem. I have to one by one download the package i need. You this is so boring?!!!!!!!!!!Is it have a easy way to install package?!!!!!!!!!!


    After listening to so many, I don't want to install yum on my debian system, but I want to know how to resolve the problem above. Thanks everyone, you are kindly. Linux's open source idea is good, but needs a lot of improvements, more humane job.
  • marcmarc Posts: 647
    dpkg doesn't deal with dependencies. "apt-get" does, "aptitude" does, dpkg *doesn't*.

    The same stands for rpm: rpm doesn't deal with dependencies, yum *does* (or urpmi in mandrake/mandriva distributions)
  • saqman2060saqman2060 Posts: 777
    @designer

    If you want to fix dependency problems using dpkg run this command
    #sudo dpgk --configure -a
  • abdallah2abdallah2 Posts: 7
    edited February 2015
    thanks all very goood topic it help me alot
    1423653810.jpg
Sign In or Register to comment.