Welcome to the new Linux Foundation Forum!

iceweasel or epiphany web browser what do i add.

what do i add.

http://www.compudiscount.com/

top bar just keep replaying . I want to read price list . it in a pdf format.

so basicly what do i need to add .

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    Iceweasel is the same as Firefox. If you add that as your web browser, you still need to add a pdf reader like evince or ghostscript, or adobe reader. (you can get evince or ghostscript from the Debian repos).
    Then in Firefox/Iceweasel go to Edit --> Preferences --> Applications type in pdf in the search line, and it will come up with PDF document. Change the Default to whatever pdf reader you chose to install and when you visit the web site, and click on the Price List, the Price List will come up after it is downloaded into the pdf reader.

    Ask if you have anymore questions.
  • debian lenny 5.03 .

    also for some reason it keep replaying the bar.
    it acts like i cant even click on it.

    evince and ghostscript are already added.
    in iceweasel there was no PDF under Applications
  • Goineasy9Goineasy9 Posts: 1,116
    Do you have Flash installed? Maybe that's the problem.
  • unknown about flash.
    i don't see it in synaptic.
  • Flash wasn't install and was not in synaptic.

    needed this in my source list.
    deb http:// www.backports.org/debian lenny-backports main contrib non-free

    flashplugin-nonfree was there
  • HI, I'm having a lot of trouble getting Flash player 10 linux to install(iceweasel browser) on Debian squeese.(i386 32 bit is the ver. the adobe tell me to d/load) I cannot get it to kick in with synaptic ( that wants to use ver 1.and asks for the disk ) I have no install discs . So need to do it all over the net.. Via bash.. I have the package downloaded and can unzip it. How do I put it where it should be and how do I access it from bash (cd ??)so that I can apt-get install the player..
    Im sure this problem has put many people off staying with Linux 6. I have been warned not to turn on backports ???
    I have tried all the solutions on the majorgeeks thread . But I cannot get over the last hurdle.

  • mfillpotmfillpot Posts: 2,180
    electricdel,
    Have you tried using "apt-get install flashplugin-nonfree" to get it from the debian repos and enabled the contrib repos to install the package at http://packages.debian.org/squeeze/flashplugin-nonfree ?
  • Goineasy9Goineasy9 Posts: 1,116
    You may also try running (as root):
    update-flashplugin-nonfree -iv
    
    If you have flashplugin-nonfree installed, it may just update flash for you without an updated flashplugin-nonfree package. I use Sid, and, flash won't update without that command, even with a sid based flashplugin-nonfree installed. Try it and see what version it updates to.
  • http://packages.debian.org/squeeze/flashplugin-nonfree *** very helpful ...But there is still something unruly goin on.
    Got some amazing updates though .. Many thanks***

    update-flashplugin-nonfree -iv The hardship is the version on box is 1.xx.xx.3.(which dosen't work on most sites) ..What I need is flashplayer 10. It,s fetched off the net. Uncompressed /Bash for some reason cannot execute.
    My command-line writing must be really flawed...

    I really need to know this so I may be able to help the next guy ..





  • mfillpotmfillpot Posts: 2,180
    Have you tried running the command that goingeasy9 gave or have you checked the debian repos to see if there is an update available for the flash player?
  • Goineasy9Goineasy9 Posts: 1,116
    If you running Debian, you don't want or need to take it off the net. You want to get it from the Debian repos. Please tell us if you tried (as root):
    apt-get install flashplugin-nonfree
    
    And tell us what happens. If you get no errors, it will have installed correctly. Then running:
    update-flashplugin-nonfree -iv
    
    Should update you to the lastest flash.

    If you do get errors running apt-get update flashplugin-nonfree, let us know what the errors are and we'll take it from there. BTW - If you copy/paste the commands directly from the forum here into your terminal, it'll make things easier.
  • Yessss!!!!Just perfect .... I've been running those lines *and getting errors* ....But with copy and paste ....BINGO...
    (I have a movie playing on another tab as I write this )....Excellent thank you .




    Next stop ...Sun java ... or something similar so I can live chat ...


    Thank you again
  • Goineasy9Goineasy9 Posts: 1,116
    If you want to install java in Debian, first try OpenJDK. It will do almost all that Sun/Oracle Java will do, without all the installation and update headaches.

    Once again as root:
    apt-get install openjdk-6-jre
    

    And to get the java browser plugin:
    apt-get install icedtea-plugin
    

    If you need java for live chat, these packages should do the trick, as I use live chat and don't have the Sun/Oracle Java installed.

    BTW - Great news that you flash is working. I've achieved success with the copy/paste of commands from forums myself, and, that's why we post the code. Just makes things easier.
  • apt-get install icedtea-plugin <this wasnt found >E: Unable to locate package icedtea-plugin

    openjdk-6-jre > so far so good no problem..thanks

  • Goineasy9Goineasy9 Posts: 1,116
    edited January 2012
    Sorry, in Debian Sid, icedtea-plugin is the name it goes by. In Squeeze, it goes by the name icedtea6-plugin. Geez, I hate when they do that.
    apt-get install icedtea6-plugin
    

    Hope that helps.

    After installing, if you go into Firefox (Iceweasel) and go to:
    Edit-->Preferencces-->General-->Manage Add-ons-->Plugins
    You should see the IcedTea-Web Plugin listed.

    Have Fun.
  • Goineasy9....
    icedtea6-plugin.....Worked and listed...Now to go wherenot many went before .....Cheers and beers ..

    Now I have a lot of reading to do ... Security and alldatstuff!!!!/ lol

    Dat was really keen
  • Goineasy9Goineasy9 Posts: 1,116
    Great news electricdel. Linux is naturally secure, although reading up on things will help you make it even more secure. Good luck, have fun and let us know if you have any more questions.
  • This is the life . total access .Blows me away what java can open up
  • Goineasy9Goineasy9 Posts: 1,116
    Sounds like you having fun, it's grat when everything is working. I don't know why some distros don't automatically include OpenJDK in their installs, I amazed sometimes when I see it's not included.
Sign In or Register to comment.