Welcome to the new Linux Foundation Forum!

ssh X11 forward problem after reinstall

after Reinstalled my SLED10 the ssh X11 froward not work.

I try it:

connect : ssh [email protected]_computer

remoted computer: export DISPLAY="mycomputer:0"

om my computer: xterm remoted_computer



in my /etc/ssh/sshd_config file


X11 forwarding yes

X11 offset 10

:(

I tried with Xauth. not solve:(

Comments

  • Death DuckDeath Duck Posts: 1
    Could be sytax; I'm not exactly sure how picky sshd is. Try changing the lines to:

    X11Forwarding no
    X11DisplayOffset 10

    and restart sshd.

    -mS
  • memmem Posts: 4
    It sounds like something is backwards...

    [local] $ ssh remote_host
    [remote] $ xterm

    The last line will display an xterm in your local computer. Your description sounds like you wish to display a window from your local computer in the remote computer, is that right? Also, ssh takes care of setting DISPLAY to the right value, you shouldn't need that.
  • Rugger1Rugger1 Posts: 1
    use the -X (captial X) in your command. i.e: ssh -X [email protected]_computer
  • LegacyUserLegacyUser Posts: 0
    Based on what you wrote, you're trying to start a program on your local machine and have a program window show up on a remote computer. In order to do that, you have to allow external X11 connections on your remote system, you can use

    on remote shell:> xhost + (will allow all hosts to connect)
    or remote shell:> xhost (name of local system, must resolve correctly)

    then on your local system, run

    local shell:> export DISPLAY=`who am i | sed 's/.*(\(.*\)).*/\1/'`

    after this, you should be able to run

    local shell:> xterm

    and it should pop up on your remote system.
  • abrenarabrenar Posts: 117
    after the export commands and display include xhost to allow server access of your computer

    hope it helps. B)
  • abrenarabrenar Posts: 117
    oppppsss the command is

    xhost +

    i forgot to include :P
  • gergelyk3gergelyk3 Posts: 11
    I am a big loser.

    I used "x" instead of "X" in ssh -X [email protected]

    :laugh:
    :laugh: :laugh: :laugh: :laugh: :laugh: :laugh: :laugh: :laugh:
Sign In or Register to comment.